Technické informace
Ÿ | Posloupnosti příkazů pro Kurzor
Ÿ | Posloupnosti příkazů pro Posouvání obrazovky
Ÿ | Posloupnosti příkazů pro Editování
Ÿ | Posloupnosti příkazů pro Vlastnosti
Ÿ | Posloupnosti příkazů pro Oznámení
Ÿ | Posloupnosti příkazů pro Různé
Ÿ | Posloupnosti příkazů pro Tiskárnu
Ÿ | Posloupnosti příkazů pro Myš
Dodatek
Ÿ | Ukázka skriptu tiskárny
Ÿ | Přenos souboru
Ÿ | Ovladač Terminfo
Ÿ | Ovladač Termcap
Ÿ | O módu PC-scancode
Webová stránka TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Často kladené otázky
© Friedrich Datentechnik GmbH. Všechna práva vyhrazena.
Informace o programu

Kurzor Ý È Þ
Příkaz | Sekvence
Posunout kurzor o # řádků nahoru | ESC [ # A
Posunout kurzor o # řádků dolů ESC [ # B
ESC [ # e
Posunout kurzor o # sloupců doprava ESC [ # C
ESC [ # a
Posunout kurzor o # sloupců doleva | ESC [ # D
Posunout kurzor o # řádků dolů; sloupec=1 | ESC [ # E
Posunout kurzor o # řádků nahoru; sloupec=1 | ESC [ # F
Uložit pozici kurzoru ESC [ s
ESC 7
Obnovit pozici kurzoru ESC [ u
ESC 8
Nastavit pozici kurzoru - řádek ; sloupec ESC [ # ; # H
ESC [ # ; # f
Posunout kurzor na řádek # | ESC [ # d
Posunout kurzor o # tabulátorů zpět | ESC [ # Z
Neblikající kurzor | ESC [ 33 h
Blikající kurzor | ESC [ 33 l
Podtržený kurzor | ESC [ 34 h
Blokovat kurzor | ESC [ 34 l
Viditelný kurzor | ESC [ ? 25 h
Neviditelný kurzor | ESC [ ? 25 l

Posouvání obrazovky Ý È Þ
Příkaz | Sekvence
Posunout o jeden řádek nahoru | ESC S
Posunout o # řádků nahoru ESC [ # S
Posunout o jeden řádek dolů | ESC T
Posunout o # řádků dolů | ESC [ # T

Editování Ý È Þ
Příkaz | Sekvence
Obrazovku vymazat od pozice kurzoru | ESC [ J
Obrazovku vymazat k pozici kurzoru | ESC [ 1 J
Vymazat obrazovku | ESC [ 2 J
Vymazat řádek od pozice kurzoru | ESC [ K
Vymazat řádek k pozici kurzoru | ESC [ 1 K
Vymazat řádek | ESC [ 2 K
Vložit # řádků | ESC [ # L
Vymazat # řádků | ESC [ # M
Vložit # znaků | ESC [ # @
Vymazat # znaků | ESC [ # P

Vlastnosti Ý È Þ
Příkaz | Sekvence
Nastavit barvu popředí | ESC [ = # F
Nastavit barvu pozadí | ESC [ = # G
Nastavit barvu popředí/pozadí | ESC [ 2 ; # ; # m
# | Barva | # | Barva
0 | černá | 8 | tmavošedá
1 | modrá | 9 | světle modrá
2 | zelená | 10 | světle zelená
3 | nebeská modř | 11 | světlá nebeská modř
4 | červená | 12 | světle červená
5 | fuchsinová | 13 | světle fuchsinová
6 | žlutá | 14 | světle žlutá
7 | šedá | 15 | bílá
Nastavení vlastností obrazovky | ESC [ # m
# | Obecné
0 | obnovit všechny vlastnosti
1 | světlé/tmavé popředí
3 | světlé pozadí
4 | podtrhnout
5 | blikat
7 | invertovat
8 | skrytý vstup
10 | vymazat MSB (grafika ascii)
11 | přepnout na čistý výstup (zobrazit všechny kódy jako znaky)
12 | nastavit MSB (grafika ascii)
27 | obnovit všechny vlastnosti (kromě barev)
# | Nastavit barvu popředí
30 | černá
31 | červená
32 | zelená
33 | žlutá
34 | modrá
35 | fuchsinová
36 | nebeská modř
37 | šedá
# | Nastavit barvu pozadí
40 | černá
41 | červená
42 | zelená
43 | žlutá
44 | modrá
45 | fuchsinová
46 | nebeská modř
47 | šedá

Oznámení Ý È Þ
Příkaz | Uvést hostitelský počítač | Odpověď TelNet98
Identifikovat terminál | ESC Z | ESC [ 98 t
Odeslat pozici kurzoru | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | podle určení
Odeslat obrazovku | ESC [ 2 i | obsah obrazovky

Různé Ý È Þ
Příkaz | Sekvence

Funkční klávesy
Vymazat všechna označení | ESC [ z
Spustit funkční klávesu # označením | ESC [ # z označení CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

Mód PC Scancode
Scancode zapnutý | ESC [ ? 34 h
Scancode vypnutý | ESC [ ? 34 l

Zalamování řádek
Zalamování řádek zapnuto | ESC [ ? 7 h
Zalamování řádek vypnuto | ESC [ ? 7 l

PC příkazy
Nastavit název relace | ESC [ x název CR
Spustit lokální PC program | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

Znaky na PC
Zobrazit znak # (=ascii) | ESC [ = # g

Rozlišení obrazovky
# řádků, # sloupců | ESC [ = # ; # R
# řádků | ESC [ = # R
# sloupců | ESC [ = 0 ; # R

Příkazy pro tiskárnu Ý È Þ
Příkaz | Sekvence
Vytisknout obrazovku | ESC [ i
Otevřít lokální tiskárnu | ESC [ 5 i
Zavřít lokální tiskárnu | ESC [ 4 i
Příklad jak používat lokální tisk

TelNet98 Rozšíření funkcí tiskárny
Následující sekvence byly vyvinuty ve Windows GDI, a proto jsou nezávislé na hardwaru jakékoli tiskárny:

Otevřít lokální tiskárnu; Orientace: na výšku | ESC [ 5 ; 30 i
Otevřít lokální tiskárnu; Orientace: na šířku | ESC [ 5 ; 31 i
Otevřít lokální tiskárnu; ukázat dialog Nastavení tiskárny | ESC [ 5 ; 32 i
EOL; Nastavit tisk k pozici 0 v současném řádku | ESC [ 5 ; 2 i
LFBACK; posun o řádek zpět | ESC [ 5 ; 3 i
CPI, # znaků na 1 palec | ESC [ 5 ; 6 ; # i
Nastavit pozici tisku ke sloupci # | ESC [ 5 ; 12 ; # i
Mód tučně (#=1/0) | ESC [ 5 ; 14 ; # i
Obnovit všechny výchozí vlastnosti | ESC [ 5 ; 17 i
Mód Podtržení (#=1/0) | ESC [ 5 ; 18 ; # i
Mód Přeškrtnuté (#=1/0) | ESC [ 5 ; 19 ; # i
Mód Dolní index (#=1/0) | ESC [ 5 ; 20 ; # i
Mód Horní index (#=1/0) | ESC [ 5 ; 21 ; # i
Mód Dvojitá výška (#=1/0) | ESC [ 5 ; 22 ; # i
Mód Dvojitá šířka (#=1/0) | ESC [ 5 ; 23 ; # i
Nastavit délku stránky na # řádků | ESC [ 5 ; 24 ; # i
LPI, # řádků na 1 palec | ESC [ 5 ; 26 ; # i
Mód Kurzíva (#=1/0) | ESC [ 5 ; 27 ; # i
Okraj - Nahoře (#=řádků) | ESC [ 5 ; 28 ; # i
Okraj - Vlevo (#=znaků) | ESC [ 5 ; 29 ; # i

Myš Ý È Þ
Příkaz | Sekvence

Posunout kurzor doleva/doprava
Umožnit | ESC [ 6 ; 1 ; 1 i
Neumožnit | ESC [ 6 ; 1 ; 0 i

Posunout kurzor nahoru/dolů
Umožnit | ESC [ 6 ; 2 ; 1 i
Neumožnit | ESC [ 6 ; 2 ; 0 i

Levé tlačítko
Neumožnit | ESC [ 6 ; 3 ; 0 i
Odeslat CR | ESC [ 6 ; 3 ; 1 i
Odeslat pozici | ESC [ 6 ; 3 ; 2 i

Ukázka skriptu tiskárny Ý È Þ

Jednoduchý shell skript pro tisk pod operačním systémem UNIX®. Skript lze použít jako příkaz i jako filtr:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Přenos souboru Ý È Þ

Přenos souborů na pozadí protokolu telnet není nejrychlejší způsob přenosu dat sítí. Přináší však vyšší komfort, protože soubor můžete přenést pouhým přetažením myši do již otevřené relace telnet. TelNet98 podporuje binární transfer založený na datovém formátu UUCODE.

Požadavky na hostitelský počítač:
  • Příkazy pro přijímání a odesílání dat ve formátu UUCODE:
    Programy uuencode a uudecode, které používané programem TelNet98 jsou obsaženy ve většině systémů UNIX®.
    Pokud u hostitelského počítače chybí - programové zdroje jsou k dispozici balíku GNU Sharutils, který lze stáhnout z Internetu nebo přes anonymní FTP.
    (např. http://www.telnet98.com/gnu/)
  • Shell, který přijímá příkazy z klávesnice (Příkazový řádek)
  • Dostatečné oprávnění na provádění těchto operací

Nahrání souboru
Doporučené kroky:
  1. Ujistěte se, že výše uvedené požadavky jsou splněny
  2. V Průzkumníkovi vyberte jeden nebo více souborů
  3. Soubor(y) přetáhněte myší do relace telnet

Stažení souboru
Doporučené kroky:
  1. Ujistěte se, že výše uvedené požadavky jsou splněny
  2. Vytvořte seznam souborů, které chcete stáhnout do obrazovky telnetu, např. použitím příkazu UNIX® ls
  3. Ze seznamu myší vyberte jeden nebo více souborů a jejich názvy zkopírujte do schránky
  4. V nabídce Relace zvolte příkaz 'Úpravy' -> 'Stáhnout soubory'
  5. V otevřeném dialogu stiskněte tlačítko 'Vložit názvy souborů ze schránky'

terminfo Ý È Þ
Tento ovladač lze použít pod operačními systémy UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Tento ovladač lze použít pod operačními systémy UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

O módu PC-scancode Ý È Þ

Narozdíl od běžných terminálů, které odesílají informace hostitelskému počítači jen ve formě klávesnicových hodnot (znaků na klávesách), terminál ovládající mód PC-scancode může posílat i skenové kódy (tzv. scancodes, tj. jedinečné hodnoty související se stisknutím a puštěním každé klávesy). Použití terminálu s modem PC-scancode umožňuje aplikaci, která v něm pracuje, přístup k detailnějším informacím o úhozech na klávesnici, než jaké by poskytl znakový mód. Nastavíte-li svůj terminál na znakový mód a stisknete např. klávesu označenou 'A', terminál odešle aplikaci jednoduchou hodnotu (ASCII hodnotu klávesy 'A'). Pokud však terminál nastavíte na mód scancode a stisknete klávesu označenou 'A', terminál pošle jednu hodnotu po stisknutí klávesy a druhou po jejím puštění. Aplikace, která pracuje v modu scancode, tyto skenové hodnoty překládá podle předem určené mapy u hostitelského počítače. Eric's TelNet98 odesílá skenové kódy hostitelskému počítači, který tuto funkci umožňuje.

Doporučené kroky pro konfiguraci vašeho systému pro mód PC-scancode*)
  1. Přeneste terminfo.src na hostitelský počítač a přeložte pomocí překladače tic:
    # tic terminfo.src
    Tím se vytvoří TERM=telnet98 term-type.

  2. V nabídce Vlastnosti relace TelNet98 nastavte term-type na telnet98

  3. Přidejte příkaz, kterým mód scancode umožníte ve svém /etc/profile (v celém systému) nebo ve svém .profile (osobní):

    např.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) testováno na systému SCO® UNIX®; na jiných systémech to může být jinak

© Friedrich Datentechnik GmbH. Všechna práva vyhrazena.


Műszaki referencia
Ÿ | Kurzor parancssorozatok
Ÿ | Görgetés parancssorozatok
Ÿ | Szerkesztés parancssorozatok
Ÿ | Jellemző parancssorozatok
Ÿ | Jelentés parancssorozatok
Ÿ | Különféle parancssorozatok
Ÿ | Nyomtató parancssorozatok
Ÿ | Egér parancssorozatok
Függelék
Ÿ | Példa a kinyomtatott szövegre
Ÿ | Fájltovábbítás
Ÿ | Terminfo vezérlőprogram
Ÿ | Termcap vezérlőprogram
Ÿ | PC letapogatási kód információ
A TelNet98 weboldala
ð | http://www.telnet98.com/
ð | F A Q - Gyakran Ismétlődő Kérdések
© Friedrich Datentechnik GmbH. Minden jog fenntartva.
Információ a TelNet98-ról

Kurzorparancsok

Ý È Þ
Parancs | Sorozat
A kurzor mozgatása # sorral felfelé | ESC [ # A
A kurzor mozgatása # sorral lefelé ESC [ # B
ESC [ # e
A kurzor mozgatása # oszloppal jobbra ESC [ # C
ESC [ # a
A kurzor mozgatása # oszloppal balra | ESC [ # D
A kurzor mozgatása # sorral lefelé | ESC [ # E
A kurzor mozgatása # sorral felfelé | ESC [ # F
Kurzorpozíció mentése ESC [ s
ESC 7
Kurzorpozíció visszaállítása ESC [ u
ESC 8
Kurzorpozíció beállítása - sor ; oszlop ESC [ # ; # H
ESC [ # ; # f
A kurzor mozgatása a(z) #. sorra | ESC [ # d
A kurzor mozgatása # tabulátorpozícióval vissza | ESC [ # Z
Állandó kurzor üzemmód | ESC [ 33 h
Villogó kurzor üzemmód | ESC [ 33 l
Aláhúzás kurzor | ESC [ 34 h
Blokk kurzor | ESC [ 34 l
Látható kurzor | ESC [ ? 25 h
Láthatatlan kurzor | ESC [ ? 25 l

Görgetési parancsok

Ý È Þ
Parancs | Sorozat
Görgetés egy sorral felfelé | ESC S
Görgetés # sorral felfelé ESC [ # S
Görgetés egy sorral lefelé | ESC T
Görgetés # sorral lefelé | ESC [ # T

Szerkesztési parancsok

Ý È Þ
Parancs | Sorozat
A képernyő törlése a kurzortól | ESC [ J
A képernyő törlése a kurzorig | ESC [ 1 J
A képernyő törlése | ESC [ 2 J
A sor törlése a kurzortól | ESC [ K
A sor törlése a kurzorig | ESC [ 1 K
A sor törlése | ESC [ 2 K
# sor beszúrása | ESC [ # L
# sor törlése | ESC [ # M
# karakter beszúrása | ESC [ # @
# karakter törlése | ESC [ # P

Jellemző parancsok

Ý È Þ
Parancs | Sorozat
Az előtér színének beállítása | ESC [ = # F
A háttér színének beállítása | ESC [ = # G
Az előtér/háttér színének beállítása | ESC [ 2 ; # ; # m
# | Szín | # | Szín
0 | fekete | 8 | sötétszürke
1 | kék | 9 | világoskék
2 | zöld | 10 | világoszöld
3 | türkiz | 11 | világos türkiz
4 | piros | 12 | világos piros
5 | bíbor | 13 | világos bíbor
6 | sárga | 14 | világossárga
7 | szürke | 15 | fehér
A képernyőjellemzők beállítása | ESC [ # m
# | Általános
0 | minden jellemző visszaállítása
1 | világos/félkövér előtér
3 | világos háttér
4 | aláhúzott
5 | villog
7 | inverz
8 | rejtett beírás
10 | MSB törlése (ASCII grafika)
11 | átváltás nyers kiírásra (minden kód karakterrel jelenik meg)
12 | MSB beállítása (ASCII grafika)
27 | minden jellemző visszaállítása (a szín kivételével)
# | Az előtér színének beállítása
30 | fekete
31 | piros
32 | zöld
33 | sárga
34 | kék
35 | bíbor
36 | türkiz
37 | szürke
# | A háttér színének beállítása
40 | fekete
41 | piros
42 | zöld
43 | sárga
44 | kék
45 | bíbor
46 | türkiz
47 | szürke

Jelentés parancsok

Ý È Þ
Parancs | A gazdagép kérése | A TelNet98 válasza
A terminál azonosítása | ESC Z | ESC [ 98 t
A kurzorpozíció küldése | ESC [ 6 n | ESC [ # ; # R
Válaszadás | ENQ | meghatározás szerint
A képernyő küldése | ESC [ 2 i | a képernyő tartalma

Vegyes parancsok

Ý È Þ
Parancs | Sorozat

Funkcióbillentyűk
Minden címke törlése | ESC [ z
A(z) # funkcióbillentyű inicializálása az címkével | ESC [ # z címke CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

PC letapogatási üzemmód
Letapogatási üzemmód be | ESC [ ? 34 h
Letapogatási üzemmód ki | ESC [ ? 34 l

Sorvégi törés
Sorvégi törés be | ESC [ ? 7 h
Sorvégi törés ki | ESC [ ? 7 l

PC parancsok
A kapcsolat nevének beállítása | ESC [ x név CR
A helyi PC program végrehajtása | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC karakterek
A(z) # (=ASCII) PC karakter megjelenítése | ESC [ = # g

A képernyő felbontása
# sor, # oszlop | ESC [ = # ; # R
# sor | ESC [ = # R
# oszlop | ESC [ = 0 ; # R

Nyomtatóparancsok

Ý È Þ
Parancs | Sorozat
Képernyő nyomtatása | ESC [ i
Helyi nyomtató megnyitása | ESC [ 5 i
Helyi nyomtató bezárása | ESC [ 4 i
Példa a helyi nyomtatás használatára

TelNet98 nyomtatóbővítések
Az alábbi sorozatokat a Windows grafikus eszközinterfész (GDI) hajtja végre, ezért minden konkrét nyomtatóhardvertől függetlenek:

Helyi nyomtató megnyitása; Tájolás: Álló | ESC [ 5 ; 30 i
Helyi nyomtató megnyitása; Tájolás: Fekvő | ESC [ 5 ; 31 i
Helyi nyomtató megnyitása; a Nyomtatóbeállítás párbeszédablak megjelenítése | ESC [ 5 ; 32 i
EOL; a nyomtatási pozíciónak az aktuális sor 0. helyére állítása | ESC [ 5 ; 2 i
LFBACK; soremelés egy sorral vissza | ESC [ 5 ; 3 i
CPI; # karakter hüvelykenként | ESC [ 5 ; 6 ; # i
A nyomtatási pozíció #. oszlopra állítása | ESC [ 5 ; 12 ; # i
Félkövér mód be/ki (#=1/0) | ESC [ 5 ; 14 ; # i
Minden jellemző alapértékre állítása | ESC [ 5 ; 17 i
Aláhúzott mód be/ki (#=1/0) | ESC [ 5 ; 18 ; # i
Áthúzott mód be/ki (#=1/0) | ESC [ 5 ; 19 ; # i
Felső index be/ki (#=1/0) | ESC [ 5 ; 20 ; # i
Alsó index be/ki (#=1/0) | ESC [ 5 ; 21 ; # i
Dupla magasság mód be/ki (#=1/0) | ESC [ 5 ; 22 ; # i
Dupla szélesség mód be/ki (#=1/0) | ESC [ 5 ; 23 ; # i
A lap hosszának beállítása # sorra | ESC [ 5 ; 24 ; # i
LPI; # sor hüvelykenként | ESC [ 5 ; 26 ; # i
Dőlt betűs mód be/ki (#=1/0) | ESC [ 5 ; 27 ; # i
Margó - Felső (#=sor) | ESC [ 5 ; 28 ; # i
Margó - Bal (#=karakter) | ESC [ 5 ; 29 ; # i

Egérparancsok

Ý È Þ
Parancs | Sorozat

Kurzor mozgatása jobbra/balra
Bekapcsolva | ESC [ 6 ; 1 ; 1 i
Kikapcsolva | ESC [ 6 ; 1 ; 0 i

Kurzor mozgatása fel/le
Bekapcsolva | ESC [ 6 ; 2 ; 1 i
Kikapcsolva | ESC [ 6 ; 2 ; 0 i

Bal oldali gomb
Kikapcsolva | ESC [ 6 ; 3 ; 0 i
Kocsivissza-jel küldése | ESC [ 6 ; 3 ; 1 i
Pozíció küldése | ESC [ 6 ; 3 ; 2 i

Példa a nyomtatási kiíratásra

Ý È Þ

Egyszerű burokeljárás az UNIX® operációs rendszer alatti nyomtatáshoz; Az eljárás parancsként és szűrőként is használható:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Fájltovábbítás

Ý È Þ

A fájlok telnet protokollon történő továbbítása nem a leggyorsabb módja az adatok hálózaton keresztüli továbbításának. Növeli azonban a kényelmi szintet, ha továbbítani tudja a fájlt úgy, hogy egyszerűen csak egy már megnyitott telnet kapcsolatba húzza az egérrel. A TelNet98 támogatja az UUCODE adatformátumon alapuló bináris továbbítást.

Követelmények a gazdagépen:
  • Utasítások az UUCODE adatok fogadására és küldésére:
    a TelNet98 által indított uuencode és uudecode már jelen van a legtöbb UNIX® rendszeren.
    Ha ezek nincsenek a gazdagépen, a programforrás elérhető a GNU Sharutils csomagban, amely anonim ftp-n keresztül letölthető az Internetről.
    (pl. http://www.telnet98.com/gnu/)
  • Egy burok, amely készen áll a billentyűzetparancsok fogadására (Parancssor)
  • Elégséges jogosultság a gazdagépen az ilyen műveletek végrehajtásához

Fájlok feltöltése
Javasolt lépések:
  1. Ellenőrizzük, hogy teljesülnek-e a fenti feltételek
  2. Válasszunk ki egy vagy több fájlt a Windows Intézőben
  3. Húzzuk a fájl(oka)t az egérrel, és tegyük rá a telnet kapcsolatra

Fejlok letöltése
Javasolt lépések:
  1. Ellenőrizzük, hogy teljesülnek-e a fenti feltételek
  2. Listázzuk ki azokat a fájlokat, amelyeket le szeretnénk tölteni a telnet képernyőre például az UNIX® ls parancsával
  3. Válasszunk ki egyet vagy többet a kilistázott fájlok közül az egérrel, és másoljuk a neveket a vágólapra
  4. A kapcsolat menüjéből válasszuk a 'Szerkesztés' -> 'Fájlok letöltése' sort
  5. A megjelenő párbeszédablakban nyomjuk le a 'Fájlnevek beillesztése a vágólapról' gombot

terminfo

Ý È Þ
Ez a vezérlőprogram az UNIX® operációs rendszerek alatt használható:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap

Ý È Þ
Ez a vezérlőprogram az UNIX® operációs rendszerek alatt használható:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

A PC-letapogatási kódról

Ý È Þ

A normál temináloktól eltérően, amelyek csak billentyű értéken (a billentyűkön megjelenő karakterek formájában) tudnak adatokat küldeni a gazdagépre, a PC-letapogatási kódra képes terminál letapogatási kódokat (az egyes billentyűk lenyomásához és felengedéséhez rendelt egyedi értékeket) is képes küldeni. A terminál PC-letapogatási üzemmódban való futtatása lehetővé teszi a letapogatási kód alkalmazás számára, hogy megkülönböztetettebb billentyűlenyomásokat küldjön, mint azt a karakteres üzemmód lehetővé teszi. Például, ha karakteres üzemmódra állítjuk a terminált, ée lenyomjuk az 'A' betűvel jelölt billentyűt, a terminál egyetlen értéket küld az alkalmazásnak (az 'A' ASCII értékét). Ha azonban letapogatási módra állítjuk a terminált, és lenyomjuk az 'A' betűvel jelölt billentyűt, a terminál küld egy értéket, amikor lenyomjuk a billentyűt, és egy másikat, amikor felengedjük azt. A letapogatási kód alkalmazás a gazdagépen lévő előre meghatározott térkép szerint fordítja le ezeket az értékeket. Ha a letapogatási kód be van kapcsolva, a TelNet98 letapogatási kódokat küld a gazdagépre.

Javasolt lépések a rendszer PC-letapogatási kód konfigurálásához*)
  1. Továbbítsa a terminfo.src fájlt a gazdagépre, és fordítsa le a tic fordítóprogram segítségével:
    # tic terminfo.src
    Ez létrehoz egy TERM=telnet98 termináltípust.

  2. A TelNet98 nyitott párbeszédablakaiban állítsa telnet98 értékre a termináltípust

  3. Adjon hozzá egy parancsot, amely bekapcsolja a letapogatási kód üzemmódot a /etc/profile profilra (az egész rendszerre) vagy a .profile profilra (csak egy gépre):

    pl.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) tesztelve a SCO® UNIX® rendszeren; más rendszereken eltérő lehet

© Friedrich Datentechnik GmbH. Minden jog fenntartva.


Odsyłacze spraw technicznych
Ÿ | Ciągi komend kursora
Ÿ | Ciągi komend przewijania
Ÿ | Ciągi komend edycji
Ÿ | Ciągi komend atrybutów
Ÿ | Ciągi komend raportów
Ÿ | Ciągi różnych komend
Ÿ | Ciągi komend drukarki
Ÿ | Ciągi komend myszy
Załącznik
Ÿ | Przykład skryptu drukowania
Ÿ | Przesyłanie plików
Ÿ | Sterownik Terminfo
Ÿ | Sterownik Termcap
Ÿ | Na temat PC-scancode
Witryna WWW TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Najczęściej zadawane pytania
© Friedrich Datentechnik GmbH. Wszystkie prawa zastrzeżone.
Informacje na temat TelNet98

Komendy kursora Ý È Þ
Komenda | Ciąg
Przesuń kursor # wierszy w górę | ESC [ # A
Przesuń kursor # wierszy w dół ESC [ # B
ESC [ # e
Przesuń kursor # kolumn w prawo ESC [ # C
ESC [ # a
Przesuń kursor # kolumn w lewo | ESC [ # D
Przesuń kursor # wierszy w dół; kolumna=1 | ESC [ # E
Przesuń kursor # wierszy w górę; kolumna=1 | ESC [ # F
Zapisz pozycję kursora ESC [ s
ESC 7
Przywróć pozycję kursora ESC [ u
ESC 8
Ustal pozycję kursora - wiersz; kolumna ESC [ # ; # H
ESC [ # ; # f
Przesuń kursor do wiersza # | ESC [ # d
Przesuń kursor # tabulatorów wstecz | ESC [ # Z
Tryb stały kursora | ESC [ 33 h
Tryb migający kursora | ESC [ 33 l
Kursor podkreślony | ESC [ 34 h
Kursor pogrubiony | ESC [ 34 l
Kursor widzialny | ESC [ ? 25 h
Kursor niewidzialny | ESC [ ? 25 l

Komendy przewijania Ý È Þ
Komenda | Ciąg
Przewiń jeden wiersz w górę | ESC S
Przewiń # wierszy w górę ESC [ # S
Przewiń jeden wiersz w dół | ESC T
Przewiń # wierszy w dół | ESC [ # T

Komendy edycji Ý È Þ
Komenda | Ciąg
Wyczyść ekran od kursora | ESC [ J
Wyczyść ekran do kursora | ESC [ 1 J
Wyczyść ekran | ESC [ 2 J
Wyczyść wiersz od kursora | ESC [ K
Wyczyść wiersz do kursora | ESC [ 1 K
Wyczyść wiersz | ESC [ 2 K
Wstaw # wierszy | ESC [ # L
Usuń # wierszy | ESC [ # M
Wstaw # znaków | ESC [ # @
Usuń # znaków | ESC [ # P

Komendy atrybutów Ý È Þ
Komenda | Ciąg
Ustaw kolor pierwszego planu | ESC [ = # F
Ustaw kolor tła | ESC [ = # G
Ustaw kolor pierwszego planu/tła | ESC [ 2 ; # ; # m
# | Kolor | # | Kolor
0 | czarny | 8 | ciemno szary
1 | niebieski | 9 | jasny niebieski
2 | zielony | 10 | jasny zielony
3 | cyjan | 11 | jasny cyjan
4 | czerwony | 12 | jasny czerwony
5 | madżenta | 13 | jasny madżenta
6 | żółty | 14 | jasny żółty
7 | szary | 15 | biały
Ustawienie atrybutów ekranu | ESC [ # m
# | Ogólne
0 | wyzeruj wszystkie atrybuty
1 | jasny/ciemny pierwszy plan
3 | jasne tło
4 | podkreślenie
5 | miganie
7 | odwrócenie
8 | ukryte wprowadzanie
10 | wyczyść MSB (grafikę ascii)
11 | przełącz na surowe dane wyjściowe (wyświetlanie wszystkich kodów jako znaków)
12 | ustaw MSB (grafikę ascii)
27 | wyzeruj wszystkie atrybuty (za wyjątkiem kolorów)
# | Ustaw kolor pierwszego planu
30 | czarny
31 | czerwony
32 | zielony
33 | żółty
34 | niebieski
35 | madżenta
36 | cyjan
37 | szary
# | Ustaw kolor tła
40 | czarny
41 | czerwony
42 | zielony
43 | żółty
44 | niebieski
45 | madżenta
46 | cyjan
47 | szary

Komendy raportów Ý È Þ
Komenda | Prośba hosta | Odpowiedź TelNet98'u
Zidentyfikuj terminal | ESC Z | ESC [ 98 t
Prześlij pozycję kursora | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | jak zdefiniowano
Prześlij ekran | ESC [ 2 i | zawartość ekranu

Różne komendy Ý È Þ
Komenda | Ciąg

Klawisze funkcyjne
Wyczyść wszystkie etykiety | ESC [ z
Inicjalizuj klawisz funkcyjny # z Etykietą | ESC [ # z etykieta CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

Tryb PC Scancode
Tryb Scancode włączony | ESC [ ? 34 h
Tryb Scancode wyłączony | ESC [ ? 34 l

Koniec zawijania wierszy
Zawijanie wierszy włączone | ESC [ ? 7 h
Zawijanie wierszy wyłączone | ESC [ ? 7 l

Komendy PC
Ustaw nazwę sesji | ESC [ x nazwa CR
Uruchom lokalny program PC | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

Znaki PC
Wyświetlaj znak PC # (=ascii) | ESC [ = # g

Rozdzielczość ekranu
# wierszy, # kolumn | ESC [ = # ; # R
# wierszy | ESC [ = # R
# kolumn | ESC [ = 0 ; # R

Komendy drukarki Ý È Þ
Komenda | Ciąg
Drukuj ekran | ESC [ i
Otwórz lokalną drukarkę | ESC [ 5 i
Zamknij lokalną drukarkę | ESC [ 4 i
Przykłady na stosowanie drukowania lokalnego

Udoskonalenia drukarek TelNet98'u
Następujące ciągi są rozwiązywane przez interfejs urządzeń graficznych Windows i dlatego są niezależne od właściwości konkretnego sprzętu drukującego:

Otwórz lokalną drukarkę, Orientacja: Pionowa | ESC [ 5 ; 30 i
Otwórz lokalną drukarkę, Orientacja: Pozioma | ESC [ 5 ; 31 i
Otwórz lokalną drukarkę, pokaż okno dialogowe Właściwości drukarki | ESC [ 5 ; 32 i
EOL; ustaw pozycję drukowania na poz. 0 w bieżącym wierszu | ESC [ 5 ; 2 i
LFBACK; przesuw wiersza jeden wiersz wstecz | ESC [ 5 ; 3 i
CPI, # znaków na cal | ESC [ 5 ; 6 ; # i
Ustaw pozycję drukowania na kolumnę # | ESC [ 5 ; 12 ; # i
Tryb pogrubienia (#=1/0) | ESC [ 5 ; 14 ; # i
Wyzeruj wszystkie atrybuty na domyślne | ESC [ 5 ; 17 i
Tryb podkreślania (#=1/0) | ESC [ 5 ; 18 ; # i
Tryb przekreślania (#=1/0) | ESC [ 5 ; 19 ; # i
Tryb indeksu dolnego (#=1/0) | ESC [ 5 ; 20 ; # i
Tryb indeksu górnego (#=1/0) | ESC [ 5 ; 21 ; # i
Tryb podwójnej wysokości (#=1/0) | ESC [ 5 ; 22 ; # i
Tryb podwójnej szerokości (#=1/0) | ESC [ 5 ; 23 ; # i
Ustaw długość strony na # wierszy | ESC [ 5 ; 24 ; # i
LPI, # wierszy na cal | ESC [ 5 ; 26 ; # i
Tryb kursywy (#=1/0) | ESC [ 5 ; 27 ; # i
Margines - Górny (#=wierszy) | ESC [ 5 ; 28 ; # i
Margines - Lewy (#=znaków) | ESC [ 5 ; 29 ; # i

Komendy myszy Ý È Þ
Komenda | Ciąg

Przesuń kursor w lewo/prawo
Włączone | ESC [ 6 ; 1 ; 1 i
Wyłączone | ESC [ 6 ; 1 ; 0 i

Przesuń kursor w górę/dół
Włączone | ESC [ 6 ; 2 ; 1 i
Wyłączone | ESC [ 6 ; 2 ; 0 i

Lewy przycisk
Wyłączone | ESC [ 6 ; 3 ; 0 i
Prześlij CR | ESC [ 6 ; 3 ; 1 i
Prześlij pozycję | ESC [ 6 ; 3 ; 2 i

Przykład Skrypti drukowania Ý È Þ

Prosty skrypt shellowy pozwalający na drukowanie pod systemem operacyjnym UNIX®. Skrypt ten może być używany jako komenda a oprócz tego jako filtr:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Przenoszenie plików Ý È Þ

Przenoszenie plików na wierzch protokołu telnet nie jest najszybszą metodą przenoszenia danych w sieci. Jednakże, zwiększa ono poziom wygody przez możliwość przeniesienia pliku zwyczajnie przez przeciągnięcie go myszą do sesji otwartej telnet. TelNet98 obsługuje przesyłanie binarne, oparte na formacie danych UUCODE.

Wymagania dotyczące Hosta:
  • Komendy odbierania i wysyłania danych UUCODE:
    uuencode oraz uudecode, przywoływane przez TelNet98, są już obecne w większości systemów UNIX®. W przypadku, kiedy brakuje ich w danym systemie, kody źródłowe programu są dostępne w pakiecie użytków GNU, dostępnym do ściągnięcia z Internetu lub poprzez anonimowy ftp.
    (np. http://www.telnet98.com/gnu/)
  • Shell gotowy do otrzymywania komend z klawiatury (wiersz poleceń)
  • Wystarczające prawa na hoście do wykonywania takich operacji

Wysyłanie plików
Sugerowane kroki:
  1. Upewnij się, ze zostały spełnione powyższe wymagania
  2. Wybierz jeden lub kilka plików w programie Eksploracja
  3. Przeciągnij plik(i) myszą i upuść je na sesję telnet

Pobieranie plików
Sugerowane kroki:
  1. Upewnij się, ze zostały spełnione powyższe wymagania
  2. Sporządź listę plików do pobrania na ekranie telnet, na przykład przez użycie komendy UNIX® ls
  3. Wybierz myszą jeden lub kilka wymienionych plików i skopiuj ich nazwy do schowka
  4. Wybierz kolejno opcje 'Edycja' -> 'Pobierz pliki' z menu sesji
  5. W pojawiającym się oknie dialogowym wciśnij przycisk 'Wklej nazwy plików ze schowka'

terminfo Ý È Þ
Sterownik ten może być używany w sytemach operacyjnych UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Sterownik ten może być używany w sytemach operacyjnych UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

PC-scancode - Informacje Ý È Þ

W przeciwieństwie do standardowych terminali, przesyłających informacje do hosta wyłącznie w postaci „na-klawiszowych" wartości (czyli tych, które są widoczne na klawiszach klawiatury), terminal obsługujący PC-scancode może również wysyłać „scan-kody" (niepowtarzalne wartości skojarzone z naciskaniem i zwalnianiem każdego klawisza). Uruchamianie terminala w trybie PC-scancode pozwala aplikacjom scankodującym na dostęp do bardziej wyraźnych przyciśnięć klawiszy niż pozwalałby na to tryb znaków. Na przykład, jeżeli ustawiono terminal w trybie znaków i wciśnięto klawisz oznaczony znakiem „A", terminal przesyła pojedynczą wartość (wartość ASCII znaku „A") do aplikacji. Jednakże w przypadku ustawienia terminalu w trybie scancode i wciśnięciu klawisza oznaczonego znakiem „A", terminal wyśle jedną wartość przy wciśnięciu klawisza i drugą przy jego zwolnieniu. Aplikacja scancode tłumaczy te wartości „skankodów" zgodnie z wstepnie określoną tablicą na hoście. Eric's TelNet98 przesyła „skankody" do hosta przy włączneniu trybu scancode..

Sugerowane kroki pozwalające na skonfigurowanie systemu PC do trybu PC-scancode*)
  1. Przenieś terminfo.src na hosta i skompiluj go przy użyciu kompilatora tic:
    # tic terminfo.src
    Stworzy to termtype TERM=telnet98.

  2. We Właściwościach Sesji TelNet98 ustaw termtype na telnet98

  3. Dodaj komendę włączającą tryb scancode do /etc/profile (działającego w całym systemie) lub do własnego .profile (wyłącznie osobiste):

    np.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) testowane na systemie SCO® UNIX®; może się trochę różnić na innych systemach

© Friedrich Datentechnik GmbH. Wszystkie prawa zastrzeżone.


Tehnične reference
Ÿ | Kazalka-Ukazne sekvence
Ÿ | Drsenje-Ukazne sekvence
Ÿ | Urejanje-Ukazne sekvence
Ÿ | Atribut-Ukazne sekvence
Ÿ | Poročilo-Ukazne sekvence
Ÿ | Razno-Ukazne sekvence
Ÿ | Tiskalnik-Ukazne sekvence
Ÿ | Miška-Ukazne sekvence
Dodatek
Ÿ | Zgled tiskanja skripta
Ÿ | Prenos datoteke
Ÿ | Gonilnik za Terminfo
Ÿ | Gonilnik za Termcap
Ÿ | Podatki o PC-scancode
Spletna stran TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Pogosto postavljena vprašanja
© Friedrich Datentechnik GmbH. Vse pravice pridržane.
Info na TelNet98

Ukazi kazalke Ý È Þ
Ukaz | Sekvenca
Premakni kazalko # vrstic navzgor | ESC [ # A
Premakni kazalko # vrstic navzdol ESC [ # B
ESC [ # e
Premakni kazalko # stolpcev desno ESC [ # C
ESC [ # a
Premakni kazalko # stolpcev levo | ESC [ # D
Premakni kazalko # vrstic navzdol; stolpec=1 | ESC [ # E
Premakni kazalko # vrstic navzgor; stolpec=1 | ESC [ # F
Shrani položaj kazalke ESC [ s
ESC 7
Obnovi položaj kazalke ESC [ u
ESC 8
Nastavi položaj kazalke - vrstica; stolpec ESC [ # ; # H
ESC [ # ; # f
Premakni kazalko v vrstico # | ESC [ # d
Premakni kazalko # tabs nazaj | ESC [ # Z
Način z mirno kazalko | ESC [ 33 h
Način z utripajočo kazalko | ESC [ 33 l
Podčrtano-Kazalka | ESC [ 34 h
Blok-Kazalka | ESC [ 34 l
Vidna kazalka | ESC [ ? 25 h
Nevidna kazalka | ESC [ ? 25 l

Ukazi za drsenje Ý È Þ
Ukaz | Sekvenca
Zdrsni za eno vrstico navzgor | ESC S
Zdrsni za # vrstic navzgor ESC [ # S
Zdrsni za eno vrstico navzdol | ESC T
Zdrsni za # vrstic navzdol | ESC [ # T

Ukazi urejanja Ý È Þ
Ukaz | Sekvenca
Počisti zaslon od kazalke navzdol | ESC [ J
Počisti zaslon od kazalke navzgor | ESC [ 1 J
Počisti zaslon | ESC [ 2 J
Počisti vrstico od kazalke na desno | ESC [ K
Počisti vrstico od kazalke na levo | ESC [ 1 K
Počisti vrstico | ESC [ 2 K
Vstavi # vrstic | ESC [ # L
Izbriši # vrstic | ESC [ # M
Vstavi # znakov | ESC [ # @
Izbriši # znakov | ESC [ # P

Ukazi atributa Ý È Þ
Ukaz | Sekvenca
Nastavi barvo ospredja | ESC [ = # F
Nastavi barvo ozadja | ESC [ = # G
Nastavi barvo za ospredje/ozadje | ESC [ 2 ; # ; # m
# | Barva | # | Barva
0 | črna | 8 | temnosiva
1 | modra | 9 | svetlomodra
2 | zelena | 10 | svetlozelena
3 | sinja | 11 | svetlosinja
4 | rdeča | 12 | svetlordeča
5 | vijolična | 13 | svetlovijolična
6 | rumena | 14 | svetlorumena
7 | siva | 15 | bela
Nastavi atribute zaslona | ESC [ # m
# | Splošno
0 | ponastavi vse atribute
1 | svetlo/krepko ospredje
3 | svetlo ozadje
4 | podčrtano
5 | utripajoče
7 | obratno
8 | skriti vnos
10 | počisti MSB (ascii grafika)
11 | vtičnica za neelementarni izhod (prikaže vse kode kot znake)
12 | nastavi MSB (ascii grafika)
27 | ponastavi vse atribute (razen barv)
# | Nastavi barvo ospredja
30 | črna
31 | rdeča
32 | zelena
33 | rumena
34 | modra
35 | vijolična
36 | sinja
37 | siva
# | Nastavi barvo ozadja
40 | črna
41 | rdeča
42 | zelena
43 | rumena
44 | modra
45 | vijolična
46 | sinja
47 | siva

Ukazi s poročanjem Ý È Þ
Ukaz | Zahteva gostitelja | Odgovor programa TelNet98
Prepoznaj terminal | ESC Z | ESC [ 98 t
Pošlji položaj kazalke | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | kot je določeno
Pošlji zaslon | ESC [ 2 i | vsebina zaslona

Različni ukazi Ý È Þ
Ukaz | Sekvenca

Funkcionalne tipke
Počisti vse vrstice | ESC [ z
Inicializiraj funkcionalno tipko # z oznako | ESC [ # z oznaka CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

Način PC Scancode
vključen način Scancode | ESC [ ? 34 h
izključen način Scancode | ESC [ ? 34 l

Konec preloma vrstice
Vključen prelom vrstice | ESC [ ? 7 h
Izključen prelom vrstice | ESC [ ? 7 l

PC ukazi
Nastavi naziv seje | ESC [ x naziv CR
Izvajanje lokalnega PC programa | ESC [ y ukaz CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC znaki
Prikaz PC znaka # (=ascii) | ESC [ = # g

Ločljivost zaslona
# vrstic, # stolpcev | ESC [ = # ; # R
# vrstic | ESC [ = # R
# stolpcev | ESC [ = 0 ; # R

Ukazi tiskalnika Ý È Þ
Ukaz | Sekvenca
Natisni zaslon | ESC [ i
Odpri lokalni tiskalnik | ESC [ 5 i
Zapri lokalni tiskalnik | ESC [ 4 i
Zgled za uporabo lokalnega tiskanja

TelNet98 Izboljšanje tiskalnika
Naslednje sekvence so razrešene s pomočjo Windows GDI in so zato neodvisne od vsakršne tiskalniške strojne opreme:

Odpri lokalni tiskalnik; Usmerjenost: Pokončna | ESC [ 5 ; 30 i
Odpri lokalni tiskalnik; Usmerjenost: Ležeča | ESC [ 5 ; 31 i
Odpri lokalni tiskalnik; pokaži pogovorno okno za nastavitev tiskalnika | ESC [ 5 ; 32 i
EOL, nastavi položaj tiskanja v pol. 0 v trenutni vrstici | ESC [ 5 ; 2 i
LFBACK, linefeed ena vrstica nazaj | ESC [ 5 ; 3 i
CPI, # znakov na palec | ESC [ 5 ; 6 ; # i
Nastavi položaj tiskanja v stolpec # | ESC [ 5 ; 12 ; # i
Krepko (#=1/0) | ESC [ 5 ; 14 ; # i
Ponastavi vse atribute na privzete | ESC [ 5 ; 17 i
Podčrtano (#=1/0) | ESC [ 5 ; 18 ; # i
Prečrtano (#=1/0) | ESC [ 5 ; 19 ; # i
Podpisano (#=1/0) | ESC [ 5 ; 20 ; # i
Nadpisano (#=1/0) | ESC [ 5 ; 21 ; # i
Orisano (#=1/0) | ESC [ 5 ; 22 ; # i
Osenčeno (#=1/0) | ESC [ 5 ; 23 ; # i
Nastavi dolžino strani na # vrstic | ESC [ 5 ; 24 ; # i
LPI, # vrstic na palec | ESC [ 5 ; 26 ; # i
Ležeče (#=1/0) | ESC [ 5 ; 27 ; # i
Robovi - Zgoraj (#=vrstic) | ESC [ 5 ; 28 ; # i
Robovi - Levo (#=znakov) | ESC [ 5 ; 29 ; # i

Ukazi miške Ý È Þ
Ukaz | Sekvenca

Premakni kazalko levo/desno
Omogočeno | ESC [ 6 ; 1 ; 1 i
Onemogočeno | ESC [ 6 ; 1 ; 0 i

Premakni kazalko gor/dol
Omogočeno | ESC [ 6 ; 2 ; 1 i
Onemogočeno | ESC [ 6 ; 2 ; 0 i

Leva tipka
Onemogočeno | ESC [ 6 ; 3 ; 0 i
Pošlji CR | ESC [ 6 ; 3 ; 1 i
Pošlji položaj | ESC [ 6 ; 3 ; 2 i

Zgled tiskanja skripta Ý È Þ

Enostavni shell script za tiskanje v UNIX® operacijskem sistemu. Skript se lahko uporablja kot ukaz in tudi kot filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Prenos datoteke Ý È Þ

Prenos datotek na vrh telnet protokola ni ravno najhitrejši način za prenos podatkov skozi omrežje. Vendar vam ta možnost omogoča udobje, da prenašate datoteke v že odprto telnet sejo le z enostavnim vlečenjem datoteke z miško. TelNet98 podpira binarni prenos, ki je izdelan na osnovi podatkov v UUCODE obliki.

Zahteve gostitelju:
  • ukazi za prejem in pošiljanje UUCODE podatkov:
    uuencode in uudecode, ki jih zahteva TelNet98, že obstajajo na večini UNIX® sistemov; če jih vaš gostitelj nima - na voljo so vam programski viri v paketih; GNU Sharutils, ki se lahko naložijo na Internetu ali prek anonymous ftp;
    (npr. http://www.telnet98.com/gnu/)
  • Shell, ki je pripravljen za prejem ukazov s tipkovnice (Command Prompt);
  • zadostne pravice gostitelja za opravljanje teh operacij.

Prenos datotek
priporočeni postopek:
  1. preverite ali so izpolnjene zgoraj omenjene zahteve;
  2. izberite eno ali več datotek z Raziskovalcem;
  3. prenesite datoteko/e z vlečenjem s pomočjo miške in jih postavite v vašo telnet sejo.

Nalaganje datotek
priporočeni postopek:
  1. preverite ali so izpolnjene zgoraj omenjene zahteve;
  2. označite datoteke, ki jih želite naložiti na vaš telnet zaslon - npr. z uporabo UNIX® ls ukaza;
  3. Izberite z miško enega ali več označenih datotek in si njihove nazive kopirajte v odložišče;
  4. iz menija seje izberite 'Urejanje' -> 'Naloži datoteke';
  5. odpre se pogovorno okno v katerem je treba pritisniti gumb 'Prilepi nazive datotek iz odložišča'.

terminfo Ý È Þ
Ta gonilnik se lahko uporablja v operacijskem sistemu UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Ta gonilnik se lahko uporablja v operacijskem sistemu UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Podatki o PC-scancode Ý È Þ

V nasprotju s standardnimi terminali so zmogljivi terminali PC-scancode sposobni, da pošiljajo tudi scancodes kode (enotne vrednosti, ki so pridružene pritisku in sprostitvi vsake posamezne tipke), medtem ko standardni terminali pošiljajo informacije gostitelju samo v obliki vrednosti tipk (znakov, ki so zapisani na vrhu tipk). Zagon terminala na PC-scancode način omogoča scancode programskem dostopu bolj razvidne kode udarcev na tipke, kot je to možno z znakovnim načinom. Na primer, če postavite terminal na znakovni način in pritisnete tipko označeno z 'A', bo terminal poslal v vaš program eno samo vrednost (ASCII vrednost za 'A'). Postavljanjem terminala na scancode način, bo udarec na tipko 'A' poslan prek terminala z dvema kodama: eno za pritisk in drugo za sprostitev tipke. Scancode program prevaja scancode vrednosti v skladu z vnaprej določenim grafičnim prikazom, katerega ima gostitelj. S pomočjo TelNet98 boste lahko pošiljali scancode kode gostitelju, če je v vašem sistemu scancode način omogočen.

Priporočamo naslednji postopek pri konfiguriranju vašega sistema za uporabo PC-scancode*)
  1. Prenesite terminfo.src na vašega gostitelja in ga prevedite s tic prevajalnikom:
    # tic terminfo.src
    tako boste ustvarili tip 'termtype' TERM=telnet98;

  2. In izberite v TelNet98 lastnosti seje in nastavite tip 'termtype' na telnet98;

  3. Dodajte ukaz 'omogoči scancode način' na vaš .profile:

    npr.
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) preizkušeno s sistemom SCO® UNIX®; z drugimi sistemi se postopek lahko razlikuje.

© Friedrich Datentechnik GmbH. Vse pravice pridržane.