Referência técnica
Ÿ | Comandos de cursor
Ÿ | Comandos de rolagem
Ÿ | Comandos de edição
Ÿ | Comandos de atribuição
Ÿ | Comandos de relatório
Ÿ | Comandos diversos
Ÿ | Comandos de impressora
Ÿ | Comandos do mouse
Apêndice
Ÿ | Exemplo de como usar a impressão local
Ÿ | Transferência de arquivos
Ÿ | Driver Terminfo
Ÿ | Driver Termcap
Ÿ | Sobre o PC-scancode
O website do TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Questões mais freqüentes
© Friedrich Datentechnik GmbH. Todos os direitos reservados.
Informação sobre o TelNet98

Comandos de cursor Ý È Þ
Comando | Seqüência
Mover cursor # linhas acima | ESC [ # A
Mover cursor # linhas abaixo ESC [ # B
ESC [ # e
Mover cursor # colunas à direita ESC [ # C
ESC [ # a
Mover cursor # colunas à esquerda | ESC [ # D
Mover cursor # linhas abaixo; col=1 | ESC [ # E
Mover cursor # linhas acima; col=1 | ESC [ # F
Salvar a posição do cursor ESC [ s
ESC 7
Restaurar a posição do cursor ESC [ u
ESC 8
Definir posição do cursor - linha ; coluna ESC [ # ; # H
ESC [ # ; # f
Mover cursor para a linha # | ESC [ # d
Mover cursor # tabs atrás | ESC [ # Z
Modo regular do cursor | ESC [ 33 h
Modo intermitente do cursor | ESC [ 33 l
Cursor em forma de grifo | ESC [ 34 h
Cursor em forma de bloco | ESC [ 34 l
Cursor visível | ESC [ ? 25 h
Cursor invisível | ESC [ ? 25 l

Comandos de rolagem Ý È Þ
Comando | Seqüência
Rolar uma linha para cima | ESC S
Rolar # linhas para cima ESC [ # S
Rolar uma linha para baixo | ESC T
Rolar # linhas para baixo | ESC [ # T

Comandos de edição Ý È Þ
Comando | Seqüência
Limpar a tela a partir do cursor | ESC [ J
Limpar a tela até o cursor | ESC [ 1 J
Limpar tela | ESC [ 2 J
Limpar a linha a partir do cursor | ESC [ K
Limpar a linha até o cursor | ESC [ 1 K
Limpar linha | ESC [ 2 K
Inserir # linhas | ESC [ # L
Excluir # linhas | ESC [ # M
Inserir # caracteres | ESC [ # @
Excluir # caracteres | ESC [ # P

Comandos de atribuição Ý È Þ
Comando | Seqüência
Definir cor de primeiro plano para # | ESC [ = # F
Definir cor de segundo plano para # | ESC [ = # G
Definir cor de primeiro plano / segundo plano | ESC [ 2 ; # ; # m
# | Cor | # | Cor
0 | preto | 8 | cinza escuro
1 | azul | 9 | azul claro
2 | verde | 10 | verde claro
3 | ciano | 11 | ciano claro
4 | vermelho | 12 | vermelho claro
5 | magenta | 13 | magenta claro
6 | amarelo | 14 | amarelo claro
7 | cinza | 15 | branco
Definir atributo de tela | ESC [ # m
# | Geral
0 | redefinir todos os atributos
1 | primeiro plano brilhante/nítido
3 | segundo plano brilhante
4 | sublinhar
5 | piscar
7 | reverter
8 | entrada oculta
10 | limpar MSB (gráficos ascii)
11 | alternar para saída bruta (exibir todos os códigos como caracteres)
12 | definir MSB (gráficos ascii)
27 | redefinir todos os atributos (com exceção das cores)
# | Definir cor de primeiro plano
30 | preto
31 | vermelho
32 | verde
33 | amarelo
34 | azul
35 | magenta
36 | ciano
37 | cinza
# | Definir cor de segundo plano
40 | preto
41 | vermelho
42 | verde
43 | amarelo
44 | azul
45 | magenta
46 | ciano
47 | cinza

Comandos de relatório Ý È Þ
Comando | Solicitação do host | Resposta do TelNet98
Identificar terminal | ESC Z | ESC [ 98 t
Enviar posição do cursor | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | como definido
Enviar tela | ESC [ 2 i | conteúdo da tela

Comandos diversos Ý È Þ
Comando | Seqüência

Teclas de função
Limpar todos os rótulos | ESC [ z
Inicializar tecla de função # com o rótulo | ESC [ # z rótulo CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

PC Modo Scancode
Modo Scancode ativado | ESC [ ? 34 h
Modo Scancode desativado | ESC [ ? 34 l

Fim da quebra de linha
Quebra de linha ativada | ESC [ ? 7 h
Quebra de linha desativada | ESC [ ? 7 l

Comandos PC
Definir nome de sessão | ESC [ x nome CR
Executar programa de PC local | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

Caracteres do PC
Exibir caractere # do PC (=ascii) | ESC [ = # g

Resolução da tela
# linhas, # colunas | ESC [ = # ; # R
# linhas | ESC [ = # R
# colunas | ESC [ = 0 ; # R

Comandos de impressora Ý È Þ
Comando | Seqüência
Imprimir tela | ESC [ i
Impressora local aberta | ESC [ 5 i
Impressora local fechada | ESC [ 4 i
Exemplo de como usar a impressão local

Aperfeiçoamentos de impressão no TelNet98
As seqüências seguintes são resolvidas pelo Windows GDI e desse modo são independentes de qualquer hardware de impressão:

Impressora local aberta; orientação: Retrato | ESC [ 5 ; 30 i
Impressora local aberta; orientação: Paisagem | ESC [ 5 ; 31 i
Impressora local aberta; mostrar diálogo de configuração da impressora | ESC [ 5 ; 32 i
EOL; definir posição de impressão como 0 na linha atual | ESC [ 5 ; 2 i
LFBACK; alimentação de linha uma linha para trás | ESC [ 5 ; 3 i
CPI, # caracteres por polegada | ESC [ 5 ; 6 ; # i
Definir posição de impressão na coluna # | ESC [ 5 ; 12 ; # i
Modo negrito lig/des (#=1/0) | ESC [ 5 ; 14 ; # i
Redefinir todos os atributos de acordo com o padrão | ESC [ 5 ; 17 i
Modo sublinhado lig/des (#=1/0) | ESC [ 5 ; 18 ; # i
modo riscado lig/des (#=1/0) | ESC [ 5 ; 19 ; # i
Modo subscrito lig/des (#=1/0) | ESC [ 5 ; 20 ; # i
Modo sobrescrito lig/des (#=1/0) | ESC [ 5 ; 21 ; # i
Modo de altura dupla lig/des (#=1/0) | ESC [ 5 ; 22 ; # i
Modo de largura dupla lig/des (#=1/0) | ESC [ 5 ; 23 ; # i
Definir o tamanho da página como # linhas | ESC [ 5 ; 24 ; # i
LPI, # linhas por polegada | ESC [ 5 ; 26 ; # i
Modo itálico lig/des (#=1/0) | ESC [ 5 ; 27 ; # i
Margem - topo (#=linhas) | ESC [ 5 ; 28 ; # i
Margem - esquerda (#=caracteres) | ESC [ 5 ; 29 ; # i

Comandos do mouse Ý È Þ
Comando | Seqüência

Mover cursor para a esquerda/direita
Ativado | ESC [ 6 ; 1 ; 1 i
Desativado | ESC [ 6 ; 1 ; 0 i

Mover cursor para cima / para baixo
Ativado | ESC [ 6 ; 2 ; 1 i
Desativado | ESC [ 6 ; 2 ; 0 i

Botão esquerdo
Desativado | ESC [ 6 ; 3 ; 0 i
Enviar CR | ESC [ 6 ; 3 ; 1 i
Enviar posição | ESC [ 6 ; 3 ; 2 i

Exemplo de como usar a impressão local Ý È Þ

Script simples de shell para impressão sob o sistema operacional UNIX®; O script pode ser usado como um comando e também como um filtro:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Transferência de arquivos Ý È Þ

A transferência de arquivos com base em um protocolo telnet não é o método mais rápido de transferir dados através de uma rede. Todavia, o nível de comodidade é maior se for possível transferir um arquivo apenas arrastando-o com o mouse em uma sessão da telnet. O TelNet98 suporta transferência binária baseada no formato de dados UUCODE.

Requisitos do host:
  • Comandos para recepção e emissão de dados codificados por UUCODE:
    uuencode e uudecode, invocados por TelNet98, já estão presentes na maior parte dos sistemas UNIX®. Caso não existam no seu host, as fontes dos programas estão disponíveis no pacote GNU Sharutils, que pode ser baixado da Internet ou obtido via ftp anônimo.
    (por exemplo, http://www.telnet98.com/gnu/)
  • Um shell pronto para receber comandos do teclado (prompt de comando)
  • Direitos suficientes no host para realizar tais operações

Upload de arquivos
Passos sugeridos:
  1. Certifique-se de que os requisitos acima estejam satisfeitos.
  2. Selecione um ou diversos arquivos no Windows Explorer
  3. Arraste o(s) arquivo(s) com o mouse e solte-os em sua sessão da telnet

Download de arquivos
Passos sugeridos:
  1. Certifique-se de que os requisitos acima estejam satisfeitos.
  2. Liste os arquivos que deseja baixar na sua tela da telnet usando, por exemplo, o comando ls do UNIX®.
  3. Selecione um ou diversos dos arquivos listados com o mouse e copie os nomes na área de transferência.
  4. Selecione 'Editar' -> Efetuar download de arquivos' no menu da sessão
  5. Na caixa de diálogo que surge pressione o botão 'Colar nomes da área de transferência'

terminfo Ý È Þ
O driver pode ser usado nos sistemas operacionais UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
O driver pode ser usado nos sistemas operacionais UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Sobre o PC-scancode Ý È Þ

Diferentemente dos terminais padrão, que enviam informações para o host apenas na forma dos valores impressos nas próprias teclas, um terminal com recursos PC-scancode pode também enviar scancodes (valores únicos associados com a pressão e a liberação de uma tecla). A operação de um terminal no modo PC-scancode permite que um aplicativo scancode obtenha uma introdução de dados por teclado mais precisa do que o modo de caracteres permitiria. Por exemplo, se você definir seu terminal para modo de caractere e pressionar a tela identificada como 'A', seu terminal envia um único valor (o valor ASCII de 'A') para seu aplicativo. Todavia, se você definir seu terminal para modo scancode e pressionar a tecla identificada como 'A', seu terminal envia um valor quando você pressiona a tecla e um segundo valor quando a libera. Um aplicativo scancode traduz esses valores scancode de acordo com um mapa pré-determinado no host. O Eric's TelNet98 envia scancodes para o host quando o modo scancode é ativado.

Passos sugeridos para configurar seu sistema para o PC-scancode*)
  1. Transfira terminfo.src para seu host e compile-o usando o compilador tic:
    # tic terminfo.src
    Isso irá criar para você um termtype TERM=telnet98

  2. No TelNet98 sua caixa de diálogo aberta atribui o termtype para telnet98

  3. Acrescente um comando para ativar o modo scancode para seu /etc/profile (por todo o sistema) ou para seu .profile (somente privado):

    por exemplo:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) testado em um sistema SCO® UNIX®; pode ser diferente em outros sistemas

© Friedrich Datentechnik GmbH. Todos os direitos reservados.


Teknisk reference
Ÿ | Markørkommandoer
Ÿ | Rullekommandoer
Ÿ | Redigeringskommandoer
Ÿ | Attributkommandoer
Ÿ | Rapporter kommandoer
Ÿ | Diverse kommandoer
Ÿ | Printerkommandoer
Ÿ | Mus kommandoer
Bilag
Ÿ | Print-script eksempel
Ÿ | Filoverførsel
Ÿ | Terminfo driver
Ÿ | Termcap driver
Ÿ | Om PC-scancode
TelNet98 Webside
ð | http://www.telnet98.com/
ð | F A Q - Frequently Asked Questions
© Friedrich Datentechnik GmbH. Alle rettigheder forbeholdes.
Info om TelNet98

Markørkommandoer Ý È Þ
Kommando | Sekvens
Flyt markør # linjer op | ESC [ # A
Flyt markør # linjer ned ESC [ # B
ESC [ # e
Flyt markør # kolonner til højre ESC [ # C
ESC [ # a
Flyt markør # kolonner til venstre | ESC [ # D
Flyt markør # linjer ned; kolonne=1 | ESC [ # E
Flyt markør # linjer op; kolonne=1 | ESC [ # F
Gem markør position ESC [ s
ESC 7
Gendan markør position ESC [ u
ESC 8
Indstil markør position linje ; kolonne ESC [ # ; # H
ESC [ # ; # f
Flyt markør til linje # | ESC [ # d
Flyt markør # tabulatorer tilbage | ESC [ # Z
Markør stilstand | ESC [ 33 h
Markør blink | ESC [ 33 l
Understregningsmarkør | ESC [ 34 h
Blokmarkør | ESC [ 34 l
Synlig markør | ESC [ ? 25 h
Usynlig markør | ESC [ ? 25 l

Rullekommandoer Ý È Þ
Kommando | Sekvens
Rul en linje op | ESC S
Rul # linjer op ESC [ # S
Rul en linje ned | ESC T
Rul # linjer ned | ESC [ # T

Redigeringskommandoer Ý È Þ
Kommando | Sekvens
Ryd skærm fra markørposition | ESC [ J
Ryd skærm til markørposition | ESC [ 1 J
Ryd skærm | ESC [ 2 J
Ryd linje fra markørposition | ESC [ K
Ryd linje til markørposition | ESC [ 1 K
Ryd linje | ESC [ 2 K
Indsæt # linjer | ESC [ # L
Slet # linjer | ESC [ # M
Indsæt # tegn | ESC [ # @
Slet # tegn | ESC [ # P

Attributkommandoer Ý È Þ
Kommando | Sekvens
Indstil forgrundsfarve | ESC [ = # F
Indstil baggrundsfarve | ESC [ = # G
Indstil forgrunds-/baggrundsfarve | ESC [ 2 ; # ; # m
# | Farve | # | Farve
0 | sort | 8 | mørkegrå
1 | blå | 9 | lyseblå
2 | grøn | 10 | lysegrøn
3 | cyan | 11 | lys cyan
4 | rød | 12 | lys rød
5 | magenta | 13 | lys magenta
6 | gul | 14 | lysegul
7 | grå | 15 | hvid
Indstil egenskaber for skærm | ESC [ # m
# | Generel
0 | nulstil alle egenskaber
1 | lys/fed skærmforgrund
3 | lys baggrund
4 | understregning
5 | blink
7 | omvendt
8 | skjult input
10 | ryd MSB (ascii grafik)
11 | skift til ufortolket output (viser alle koder som tegn)
12 | indstil MSB (ascii grafik)
27 | nulstil alle egenskaber (undtagen farver)
# | Indstil forgrundsfarve
30 | sort
31 | rød
32 | grøn
33 | gul
34 | blå
35 | magenta
36 | cyan
37 | grå
# | Indstil baggrundsfarve
40 | sort
41 | rød
42 | grøn
43 | gul
44 | blå
45 | magenta
46 | cyan
47 | grå

Rapporter kommandoer Ý È Þ
Kommando | Værtsanmodning | TelNet98s svar
Identificer terminal | ESC Z | ESC [ 98 t
Send markør position | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | som defineret
Send skærm | ESC [ 2 i | skærmindhold

Diverse kommandoer Ý È Þ
Kommando | Sekvens

Funktionstaster
Ryd alle betegnelser | ESC [ z
Påbegynd funktionstast # med betegnelsen | ESC [ # z betegnelse CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SKIFT>+F1 | - <SKIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SKIFT>+F1 | - <CTRL>+<SKIFT>+F12

PC scancode tilstand
Scancode til | ESC [ ? 34 h
Scancode fra | ESC [ ? 34 l

Slutning af linjeombrydning
Linjeombrydning til | ESC [ ? 7 h
Linjeombrydning fra | ESC [ ? 7 l

PC kommandoer
Indstil sessionsnavn | ESC [ x navn CR
Kør lokalt PC program | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC tegn
Vis PC tegn # (=ascii) | ESC [ = # g

Skærmopløsning
# linjer, # kolonner | ESC [ = # ; # R
# linjer | ESC [ = # R
# kolonner | ESC [ = 0 ; # R

Printerkommandoer Ý È Þ
Kommando | Sekvens
Print skærm | ESC [ i
Åbn lokal printer | ESC [ 5 i
Luk lokal printer | ESC [ 4 i
Eksempel på brug af lokal printer

TelNet98 Printer optimering
De følgende sekvenser udføres af Windows GDI og er derfor uafhængige af det enkelte printer hardware:

Åbn lokal printer; Papirretning: Stående | ESC [ 5 ; 30 i
Åbn lokal printer; Papirretning: Liggende | ESC [ 5 ; 31 i
Åbn lokal printer; vis printerindstilling dialogboks | ESC [ 5 ; 32 i
EOL; indstil printposition til pos 0 i den aktuelle linje | ESC [ 5 ; 2 i
LFBACK; linjeskift en linje tilbage | ESC [ 5 ; 3 i
CPI, # tegn pr. tomme | ESC [ 5 ; 6 ; # i
Indstil printposition til kolonne # | ESC [ 5 ; 12 ; # i
Fed til/fra (#=1/0) | ESC [ 5 ; 14 ; # i
Gendan alle egenskaber til standardindstillinger | ESC [ 5 ; 17 i
Understregning til/fra (#=1/0) | ESC [ 5 ; 18 ; # i
Gennemstreget til/fra (#=1/0) | ESC [ 5 ; 19 ; # i
Subscript til/fra (#=1/0) | ESC [ 5 ; 20 ; # i
Superscript til/fra (#=1/0) | ESC [ 5 ; 21 ; # i
Dobbelt højde til/fra (#=1/0) | ESC [ 5 ; 22 ; # i
Dobbelt bredde til/fra (#=1/0) | ESC [ 5 ; 23 ; # i
Indstil sidelængde til # linjer | ESC [ 5 ; 24 ; # i
LPI, # linjer pr. tomme | ESC [ 5 ; 26 ; # i
Kursiv til/fra (#=1/0) | ESC [ 5 ; 27 ; # i
Margen - Øverst (#=linjer) | ESC [ 5 ; 28 ; # i
Margen - Venstre (#=tegn) | ESC [ 5 ; 29 ; # i

Mus kommandoer Ý È Þ
Kommando | Sekvens

Flyt markøren til venstre/højre
Aktiveret | ESC [ 6 ; 1 ; 1 i
Deaktiveret | ESC [ 6 ; 1 ; 0 i

Flyt markøren op/ned
Aktiveret | ESC [ 6 ; 2 ; 1 i
Deaktiveret | ESC [ 6 ; 2 ; 0 i

Venstre tast
Deaktiveret | ESC [ 6 ; 3 ; 0 i
Send CR | ESC [ 6 ; 3 ; 1 i
Send position | ESC [ 6 ; 3 ; 2 i

Print-script eksempel Ý È Þ

Simpel shell script til print under UNIX® operativ system. Scriptet kan bruges som kommando eller som filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Filoverførsel Ý È Þ

Overførsel af filer til en telnet protokol er ikke den hurtigste måde at overføre data på gennem et netværk. Det gør det dog nemmere, hvis man kan overføre filer ved at trække dem over i en allerede åben telnet session ved hjælp af musen. TelNet98 understøtter binære overførsler, baseret på UUCODE data format.

Krav til værten:
  • Kommandoer til modtagelse og afsendelse af UUCODE data:
    uuencode og uudecode, som behandles af TelNet98, findes allerede i de fleste UNIX® systemer. Hvis de ikke findes på din vært, er programressourcerne tilgængelige i GNU Sharutils pakken, som kan downloades fra Internettet eller via anonym ftp.
    (f.eks. http://www.telnet98.com/gnu/)
  • En shell, som allerede er parat til at modtage kommandoer fra tastaturet (Kommandoprompt)
  • Tilstrækkelige rettigheder på værten til at udføre de pågældende operationer

Upload af fil
Forslåede trin:
  1. Kontroller at ovennævnte krav er opfyldt
  2. Vælg en fil i Windows Stifinder
  3. Træk filen/filerne med musen over i din telnet session

Download af fil
Forslåede trin:
  1. Kontroller at ovennævnte krav er opfyldt
  2. Vælg de filer du vil downloade til din telnet skærm, for eksempel ved hjælp af UNIX® ls kommando
  3. Vælg en eller flere af de listede filer med musen og kopier navnene til udklipsholderen
  4. Vælg 'Rediger' -> 'Download filer' fra sessionsmenuen
  5. I dialogboksen vælges 'Indsæt filnavne fra Udklipsholder' knappen

terminfo Ý È Þ
Denne driver kan anvendes under UNIX® operativsystemer:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Denne driver kan anvendes under UNIX® operativsystemer:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Om PC-scancode Ý È Þ

I modsætning til standard terminaler, som kun sender information til værten i form af tasternes værdier (de tegn der vises på tasterne), kan en terminal der understøtter PC-scancode sende scankoder (entydige værdier der associeres ved tryk på tasterne). Hvis en terminal køres i PC-scancode tilstand, kan man med scancode funktionen opnå mere særskilte tastetryk end i tegntilstand. For eksempel, hvis du indstiller din terminal til tegntilstand og trykker på tasten 'A', vil din terminal sende et enkelt værdi (ASCII værdien af 'A') til dit program. Hvis du derimod indstiller din terminal til scancode tilstand og trykker på tasten 'A', sender din terminal en værdi når du trykker tasten ned og en anden værdi når du slipper tasten. Scancode funktionen oversætter disse scancode værdier i overensstemmelse med en forudbestemt oversigt på værten. Eric's TelNet98 sender scankoder til værten, når scancode tilstand er aktiveret.

Foreslåede trin til konfigurering af dit system til PC-scancode*)
  1. Overfør terminfo.src til din vært og oversæt den ved hjælp af tic compiler:
    # tic terminfo.src
    Dette vil oprette en TERM=telnet98 termtype.

  2. I TelNet98s åbne dialogboks skal termtypen indstilles til telnet98

  3. Tilføj en kommando for at aktivere scancode tilstand på din /etc/profile (hele systemet) eller på din .profile (kun privat):

    f.eks.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) testet på et SCO® UNIX® system; det kan være anderledes på andre systemer

© Friedrich Datentechnik GmbH. Alle rettigheder forbeholdes.


Technische informatie
Ÿ | Opdrachten voor cursor
Ÿ | Opdrachten voor schuiven
Ÿ | Opdrachten voor bewerkingen
Ÿ | Opdrachten voor kenmerken
Ÿ | Opdrachten voor rapporteren
Ÿ | Diverse opdrachten
Ÿ | Opdrachten voor afdrukken
Ÿ | Opdrachten voor muis
Bijlage
Ÿ | Voorbeeld van afdrukscript
Ÿ | Bestandsoverdracht
Ÿ | Stuurprogramma Terminfo
Ÿ | Stuurprogramma Termcap
Ÿ | Informatie over PC-scancode
De website TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Veelgestelde vragen
© Friedrich Datentechnik GmbH. Alle rechten voorbehouden.
Informatie over TelNet98

Opdrachten voor cursor Ý È Þ
Opdracht | Tekenreeks
Cursor # regels omhoog verplaatsen | ESC [ # A
Cursor # regels omlaag verplaatsen ESC [ # B
ESC [ # e
Cursor # kolommen naar rechts verplaatsen ESC [ # C
ESC [ # a
Cursor # kolommen naar links verplaatsen | ESC [ # D
Cursor # regels omlaag verplaatsen; kolom=1 | ESC [ # E
Cursor # regels omhoog verplaatsen; kolom=1 | ESC [ # F
Cursorpositie opslaan ESC [ s
ESC 7
Cursorpositie herstellen ESC [ u
ESC 8
Cursorpositie instellen regel ; kolom ESC [ # ; # H
ESC [ # ; # f
Cursor naar regel # verplaatsen | ESC [ # d
Cursor # tabs terugplaatsen | ESC [ # Z
Cursor in vaste modus | ESC [ 33 h
Cursor in knippermodus | ESC [ 33 l
Cursor als onderstrepingsteken | ESC [ 34 h
Cursor als blokje | ESC [ 34 l
Zichtbare cursor | ESC [ ? 25 h
Onzichtbare cursor | ESC [ ? 25 l

Opdrachten voor schuiven Ý È Þ
Opdracht | Tekenreeks
Een regel omhoog schuiven | ESC S
# regels omhoog schuiven ESC [ # S
Een regel omlaag schuiven | ESC T
# regels omlaag schuiven | ESC [ # T

Opdrachten voor bewerkingen Ý È Þ
Opdracht | Tekenreeks
Scherm wissen vanaf cursorpositie | ESC [ J
Scherm wissen tot cursorpositie | ESC [ 1 J
Scherm wissen | ESC [ 2 J
Regel wissen vanaf cursorpositie | ESC [ K
Regel wissen tot cursorpositie | ESC [ 1 K
Regel wissen | ESC [ 2 K
# regels invoegen | ESC [ # L
# regels verwijderen | ESC [ # M
# tekens invoegen | ESC [ # @
# tekens verwijderen | ESC [ # P

Opdrachten voor kenmerken Ý È Þ
Opdracht | Tekenreeks
Voorgrondkleur instellen | ESC [ = # F
Achtergrondkleur instellen | ESC [ = # G
Voorgrond-/achtergrondkleur instellen | ESC [ 2 ; # ; # m
# | Kleur | # | Kleur
0 | zwart | 8 | donkergrijs
1 | blauw | 9 | lichtblauw
2 | groen | 10 | lichtgroen
3 | cyaan | 11 | lichtcyaan
4 | rood | 12 | lichtrood
5 | magenta | 13 | lichtmagenta
6 | geel | 14 | lichtgeel
7 | grijs | 15 | wit
Schermkenmerk instellen | ESC [ # m
# | Algemeen
0 | alle kenmerken opnieuw instellen
1 | heldere/vette voorgrond
3 | heldere achtergrond
4 | onderstrepen
5 | knipperen
7 | omkeren
8 | verborgen invoer
10 | MSB wissen (ASCII-afbeeldingen)
11 | naar onbewerkte uitvoer overschakelen (alle codes als tekens weergeven)
12 | MSB instellen (ASCII-afbeeldingen)
27 | alle kenmerken opnieuw instellen (met uitzondering van kleuren)
# | Voorgrondkleur instellen
30 | zwart
31 | rood
32 | groen
33 | geel
34 | blauw
35 | magenta
36 | cyaan
37 | grijs
# | Achtergrondkleur instellen
30 | zwart
31 | rood
32 | groen
33 | geel
34 | blauw
35 | magenta
36 | cyaan
37 | grijs

Opdrachten voor rapporteren Ý È Þ
Opdracht | Hostaanvraag | Antwoord van TelNet98
Terminal identificeren | ESC Z | ESC [ 98 t
Cursorpositie verzenden | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | Zoals is gedefinieerd
Scherm verzenden | ESC [ 2 i | Scherminhoud

Diverse opdrachten Ý È Þ
Opdracht | Tekenreeks

Functietoetsen
Alle labels wissen | ESC [ z
Functietoets # initialiseren met label | ESC [ # z label CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

PC-scancodemodus
PC-scancodemodus aan | ESC [ ? 34 h
PC-scancodemodus uit | ESC [ ? 34 l

Regelterugloop
Regelterugloop aan | ESC [ ? 7 h
Regelterugloop uit | ESC [ ? 7 l

PC-opdrachten
Sessienaam instellen | ESC [ x naam CR
Lokaal PC-programma uitvoeren | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC-tekens
PC-teken # (=ASCII) weergeven | ESC [ = # g

Schermresolutie
# regels, # kolommen | ESC [ = # ; # R
# regels | ESC [ = # R
# kolommen | ESC [ = 0 ; # R

Opdrachten voor afdrukken Ý È Þ
Opdracht | Tekenreeks
Scherm afdrukken | ESC [ i
Lokale printer openen | ESC [ 5 i
Lokale printer sluiten | ESC [ 4 i
Voorbeeld van lokale afdrukopdracht

Afdrukuitbreidingen van TelNet98
De volgende functies worden uitgevoerd met Windows GDI en zijn bijgevolg onafhankelijk van specifieke printerhardware:

Lokale printer openen; Afdrukstand: Staand | ESC [ 5 ; 30 i
Lokale printer openen; Afdrukstand: Liggend | ESC [ 5 ; 31 i
Lokale printer openen; dialoogvenster Printerinstelling weergeven | ESC [ 5 ; 32 i
EOL; afdrukpositie instellen op positie 0 van de huidige regel | ESC [ 5 ; 2 i
LFBACK; regelinvoer één regel omhoog | ESC [ 5 ; 3 i
CPI, # tekens per inch | ESC [ 5 ; 6 ; # i
Afdrukpositie instellen op kolom # | ESC [ 5 ; 12 ; # i
Vette modus aan/uit (#=1/0) | ESC [ 5 ; 14 ; # i
Alle kenmerken opnieuw instellen op standaardwaarden | ESC [ 5 ; 17 i
Onderstrepingsmodus aan/uit (#=1/0) | ESC [ 5 ; 18 ; # i
Doorhalingsmodus aan/uit (#=1/0) | ESC [ 5 ; 19 ; # i
Subscriptmodus aan/uit (#=1/0) | ESC [ 5 ; 20 ; # i
Superscriptmodus aan/uit (#=1/0) | ESC [ 5 ; 21 ; # i
Dubbele-hoogtemodus aan/uit (#=1/0) | ESC [ 5 ; 22 ; # i
Dubbele-breedtemodus aan/uit (#=1/0) | ESC [ 5 ; 23 ; # i
Paginalengte instellen op # regels | ESC [ 5 ; 24 ; # i
LPI, # regels per inch | ESC [ 5 ; 26 ; # i
Cursiefmodus aan/uit (#=1/0) | ESC [ 5 ; 27 ; # i
Bovenmarge (#=regels) | ESC [ 5 ; 28 ; # i
Linkermarge (#=tekens) | ESC [ 5 ; 29 ; # i

Opdrachten voor muis Ý È Þ
Opdracht | Tekenreeks

Cursor horizontaal verplaatsen
Ingeschakeld | ESC [ 6 ; 1 ; 1 i
Uitgeschakeld | ESC [ 6 ; 1 ; 0 i

Cursor verticaal verplaatsen
Ingeschakeld | ESC [ 6 ; 2 ; 1 i
Uitgeschakeld | ESC [ 6 ; 2 ; 0 i

Linkerknop
Uitgeschakeld | ESC [ 6 ; 3 ; 0 i
CR verzenden | ESC [ 6 ; 3 ; 1 i
Positie verzenden | ESC [ 6 ; 3 ; 2 i

Voorbeeld van afdrukscript Ý È Þ

Eenvoudig shellscript voor afdrukken onder het UNIX®-besturingssysteem. U kunt het script gebruiken als opdracht, maar ook als filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Bestandsoverdracht Ý È Þ

Bestanden overbrengen via een telnetprotocol is niet de snelste manier om gegevens via een netwerk te transporteren. Het is echter bijzonder handig als u een bestand kunt overbrengen door dit met de muis naar een telnetsessie te slepen, die reeds is geopend. TelNet98 ondersteunt binaire overdracht op basis van een UUCODE gegevensindeling.

Vereisten op de host:
  • Opdrachten waarmee u UUCODE gegevens ontvangt en verzendt:
    uuencode en uudecode, die worden aangeroepen door TelNet98, zijn reeds aanwezig op het merendeel van de UNIX®-systemen. Als deze opdrachten ontbreken op de host, kunt u deze vinden in het GNU Sharutils-pakket, dat u kunt downloaden vanaf het Internet of een anonieme ftp-site.
    (bijvoorbeeld http://www.telnet98.com/gnu/)
  • Een shell, die opdrachten van het toetsenbord kan ontvangen (opdrachtprompt)
  • Voldoende rechten op de host voor het uitvoeren van dergelijke bewerkingen

Bestand uploaden
Voorgestelde stappen:
  1. Controleer of aan bovenstaande vereisten is voldaan
  2. Selecteer een of meer bestanden in Windows Verkenner
  3. Sleep één of meer bestanden met de muis en laat deze los in de telnetsessie

Bestand downloaden
Voorgestelde stappen:
  1. Controleer of aan bovenstaande vereisten is voldaan
  2. Geef in het telnetscherm een lijst met bestanden weer die u wilt downloaden, bijvoorbeeld met de opdracht UNIX® ls
  3. Selecteer één of meer van de weergegeven bestanden met de muis en kopieer de namen naar het Klembord
  4. Kies 'Bewerken' -> 'Bestanden downloaden' in het sessiemenu
  5. Klik in het dialoogvenster dat verschijnt, op de knop 'Bestandsnamen vanaf Klembord plakken'

terminfo Ý È Þ
U kunt dit stuurprogramma gebruiken onder UNIX®-besturingssystemen:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
U kunt dit stuurprogramma gebruiken onder UNIX®-besturingssystemen:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Informatie over PC-scancode Ý È Þ

In tegenstelling tot standaardterminals, waarmee informatie naar de host wordt verzonden als toetslabelwaarden (de tekens die op het bovenvlak van de toetsen zijn weergegeven), kan een terminal met PC-scancodecapaciteit tevens scancodes verzenden (unieke waarden die aan het indrukken en loslaten van elke toets zijn gekoppeld). Als u een terminal in de PC-scancodemodus uitvoert, kunt u met een scancodetoepassing toegang krijgen tot meer verschillende toetsaanslagen dan met de tekenmodus. Als u de terminal instelt op de tekenmodus en bijvoorbeeld op de toets met het label 'A' drukt, verzendt de terminal een enkele waarde (de ASCII-waarde 'A') naar de toepassing. Als u de terminal instelt op de scancodemodus en bijvoorbeeld op de toets met het label 'A' drukt, verzendt de terminal een waarde wanneer u op de toets drukt en een tweede waarde wanneer u de toets loslaat. Een scancodetoepassing vertaalt deze scancodewaarden overeenkomstig een vooraf bepaalde indeling op de host. Wanneer de scancodemodus is ingeschakeld, verzendt Eric's TelNet98 scancodes naar de host.

Voorgestelde stappen voor het configureren van het systeem voor PC-scancode*)
  1. Breng terminfo.src over naar de host en compileer het stuurprogramma met het tic-compileerprogramma:
    # tic terminfo.src
    Hiermee maakt u een term van het type TERM=telnet98.

  2. Stel in het dialoogvenster Openen van TelNet98 het termtype in op telnet98

  3. Voeg een opdracht toe om de scancodemodus in te schakelen voor /etc/profile (hele systeem) of .profile (alleen persoonlijk):

    bijvoorbeeld:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) Getest op een SCO® UNIX®-systeem; kan anders zijn op andere systemen.

© Friedrich Datentechnik GmbH. Alle rechten voorbehouden.


Technical Reference
Ÿ | Cursor Command Sequences
Ÿ | Scroll Command Sequences
Ÿ | Edit Command Sequences
Ÿ | Attribute Command Sequences
Ÿ | Report Command Sequences
Ÿ | Miscellaneous Command Sequences
Ÿ | Printer Command Sequences
Ÿ | Mouse Command Sequences
Appendix
Ÿ | Print Script Example
Ÿ | File Transfer
Ÿ | Terminfo Driver
Ÿ | Termcap Driver
Ÿ | About PC-scancode
The TelNet98 Web Site
ð | http://www.telnet98.com/
ð | F A Q - Frequently Asked Questions
© Friedrich Datentechnik GmbH. All rights reserved.
Info on TelNet98

Cursor Commands Ý È Þ
Command | Sequence
Move cursor # lines up | ESC [ # A
Move cursor # lines down ESC [ # B
ESC [ # e
Move cursor # columns right ESC [ # C
ESC [ # a
Move cursor # columns left | ESC [ # D
Move cursor # lines down; col=1 | ESC [ # E
Move cursor # lines up; col=1 | ESC [ # F
Save cursor position ESC [ s
ESC 7
Restore cursor position ESC [ u
ESC 8
Set cursor position line ; column ESC [ # ; # H
ESC [ # ; # f
Move cursor to line # | ESC [ # d
Move cursor # tabs back | ESC [ # Z
Cursor steady mode | ESC [ 33 h
Cursor blink mode | ESC [ 33 l
Underline cursor | ESC [ 34 h
Block Cursor | ESC [ 34 l
Cursor visible | ESC [ ? 25 h
Cursor invisible | ESC [ ? 25 l

Scroll Commands Ý È Þ
Command | Sequence
Scroll one line up | ESC S
Scroll # lines up ESC [ # S
Scroll one line down | ESC T
Scroll # lines down | ESC [ # T

Edit Commands Ý È Þ
Command | Sequence
Clear screen from cursor | ESC [ J
Clear screen to cursor | ESC [ 1 J
Clear screen | ESC [ 2 J
Clear line from cursor | ESC [ K
Clear line to cursor | ESC [ 1 K
Clear line | ESC [ 2 K
Insert # lines | ESC [ # L
Delete # lines | ESC [ # M
Insert # characters | ESC [ # @
Delete # characters | ESC [ # P

Attribute Commands Ý È Þ
Command | Sequence
Set foreground color to # | ESC [ = # F
Set background color to # | ESC [ = # G
Set foreground/background color | ESC [ 2 ; # ; # m
# | Color | # | Color
0 | black | 8 | dark gray
1 | blue | 9 | light blue
2 | green | 10 | light green
3 | cyan | 11 | light cyan
4 | red | 12 | light red
5 | magenta | 13 | light magenta
6 | yellow | 14 | light yellow
7 | gray | 15 | white
Set screen attribute | ESC [ # m
# | General
0 | reset all attributes
1 | bright/bold foreground
3 | bright background
4 | underline
5 | blink
7 | reverse
8 | hidden input
10 | clear MSB (ascii graphics)
11 | switch to raw output (display all codes as characters)
12 | set MSB (ascii graphics)
27 | reset all attributes (except colors)
# | Set foreground color
30 | black
31 | red
32 | green
33 | yellow
34 | blue
35 | magenta
36 | cyan
37 | gray
# | Set background color
40 | black
41 | red
42 | green
43 | yellow
44 | blue
45 | magenta
46 | cyan
47 | gray

Report Commands Ý È Þ
Command | Host Request | TelNet98 Response
Identify Terminal | ESC Z | ESC [ 98 t
Send Cursor Position | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | as defined
Send Screen | ESC [ 2 i | screen content

Miscellaneous Commands Ý È Þ
Command | Sequence

Function Keys
Clear all Labels | ESC [ z
Initialize function key # with Label | ESC [ # z label CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

PC Scancode Mode
Scancode mode on | ESC [ ? 34 h
Scancode mode off | ESC [ ? 34 l

End of Line Wrap
Line wrap on | ESC [ ? 7 h
Line wrap off | ESC [ ? 7 l

PC Commands
Set session name | ESC [ x name CR
Execute local PC program | ESC [ y cmd CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC Characters
Display PC character # (=ascii) | ESC [ = # g

Screen Resolution
# Lines, # Columns | ESC [ = # ; # R
# Lines | ESC [ = # R
# Columns | ESC [ = 0 ; # R

Printer Commands Ý È Þ
Command | Sequence
Print screen | ESC [ i
Open local printer | ESC [ 5 i
Close local printer | ESC [ 4 i
Example of how to use local printing

TelNet98 Printer Enhancements
The following sequences are resolved by Windows GDI and therefore they are independent of any specific printer hardware:

Select printer | ESC [ = p name CR
Open local printer; Orientation: Portrait | ESC [ 5 ; 30 i
Open local printer; Orientation: Landscape | ESC [ 5 ; 31 i
Open local printer; show Print Setup dialog | ESC [ 5 ; 32 i
EOL; set print position to pos 0 in the current line | ESC [ 5 ; 2 i
LFBACK; linefeed one line back | ESC [ 5 ; 3 i
CPI, # characters per inch | ESC [ 5 ; 6 ; # i
Set print position to column # | ESC [ 5 ; 12 ; # i
Bold mode on/off (#=1/0) | ESC [ 5 ; 14 ; # i
Reset all attributes to default | ESC [ 5 ; 17 i
Underline mode on/off (#=1/0) | ESC [ 5 ; 18 ; # i
Strikeout mode on/off (#=1/0) | ESC [ 5 ; 19 ; # i
Subscript mode on/off (#=1/0) | ESC [ 5 ; 20 ; # i
Superscript mode on/off (#=1/0) | ESC [ 5 ; 21 ; # i
Double height mode on/off (#=1/0) | ESC [ 5 ; 22 ; # i
Double width mode on/off (#=1/0) | ESC [ 5 ; 23 ; # i
Set pagelength to # lines | ESC [ 5 ; 24 ; # i
LPI, # lines per inch | ESC [ 5 ; 26 ; # i
Italic mode on/off (#=1/0) | ESC [ 5 ; 27 ; # i
Margin - Top (#=lines) | ESC [ 5 ; 28 ; # i
Margin - Left (#=characters) | ESC [ 5 ; 29 ; # i

Mouse Commands Ý È Þ
Command | Sequence

Move Cursor Left/Right
Enabled | ESC [ 6 ; 1 ; 1 i
Disabled | ESC [ 6 ; 1 ; 0 i

Move Cursor Up/Down
Enabled | ESC [ 6 ; 2 ; 1 i
Disabled | ESC [ 6 ; 2 ; 0 i

Left Button
Disabled | ESC [ 6 ; 3 ; 0 i
Send CR | ESC [ 6 ; 3 ; 1 i
Send position | ESC [ 6 ; 3 ; 2 i

Print Script Example Ý È Þ

Simple shell script for printing under the UNIX® operating system; The script can be use as a command and also as a filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

File Transfer Ý È Þ

Transferring files on top of a telnet protocol is not the fastest method to transport data through a network. However, it increases the comfort level if you can transfer a file by just dragging it with the mouse into a telnet session, which is already opened. TelNet98 supports binary transfer, based on UUCODE data format.

Requirements on the Host:
  • Commands to receive and send uuencoded data:
    uuencode and uudecode, which are invoked by TelNet98, are already present on the most UNIX® systems. If those should be missing on your host - the programm sources are available in the GNU Sharutils package, which can be downloaded from the internet or via anonymous ftp.
    (e.g. http://www.telnet98.com/gnu/)
  • A shell, which is ready to receive commands from the keyboard (Command Prompt)
  • Sufficient rights on the host to perform such operations

File Upload
Suggested steps:
  1. Make sure, the above requirements do match
  2. Select one or several files in Windows Explorer
  3. Drag the file(s) with the mouse and drop them into your telnet session

File Download
Suggested steps:
  1. Make sure, the above requirements do match
  2. List the files you want to download on your telnet screen, for example by using the UNIX® ls command
  3. Select one or several of the listed files with the mouse and copy the names into the clipboard
  4. Choose the 'Edit' -> 'Download Files' item from the session menu
  5. In the appearing dialog box press the 'Paste Filenames from Clipboard' button

terminfo Ý È Þ
This driver can be used under UNIX® operating systems:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
This driver can be used under UNIX® operating systems:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

About PC-scancode Ý È Þ

Unlike standard terminals, which send information to the host only in the form of keytop values (the characters that appear on the faces of the keys), a PC-scancode capable terminal can also send scancodes (unique values associated with the depression and release of each key). Running a terminal in PC-scancode mode lets a scancode application access more distinct keystrokes than character mode would provide. For example, if you set your terminal to character mode and press the key labeled 'A', your terminal sends a single value (the ASCII value of 'A') to your application. However, if you set your terminal to scancode mode and press the key labeled 'A', your terminal sends one value when you depress the key and a second value when you release the key. A scancode application translates these scancode values according to a predetermined map on the host. Eric's TelNet98 sends scancodes to the host, when scancode mode is enabled.

Suggested steps to configure your system for PC-scancode*)
  1. Transfer terminfo.src to your host and compile it using the tic compiler:
    # tic terminfo.src
    This will create you a TERM=telnet98 termtype.

  2. In TelNet98's open dialog set the termtype to telnet98

  3. Add a command to enable scancode mode to your /etc/profile (system wide) or to your .profile (private only):

    e. g.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) tested on a SCO® UNIX® system; might be different on other systems

© Friedrich Datentechnik GmbH. All rights reserved.


Tekniset tiedot
Ÿ | Kohdistimen komentojaksot
Ÿ | Vierityksen komentojaksot
Ÿ | Muokkauksen komentojaksot
Ÿ | Attribuuttien komentojaksot
Ÿ | Raporttien komentojaksot
Ÿ | Sekalaiset komentojaksot
Ÿ | Tulostimen komentojaksot
Ÿ | Hiiren komentojaksot
Liite
Ÿ | Tulostuskomentosarjan malli
Ÿ | Tiedostonsiirto
Ÿ | Terminfo-ohjain
Ÿ | Termcap-ohjain
Ÿ | Tietoja PC-scancode-koodista
TelNet98:n Web-sivusto
ð | http://www.telnet98.com/
ð | F A Q - Usein kysytyt kysymykset
© Friedrich Datentechnik GmbH. Kaikki oikeudet pidetään.
Tietoja TelNet98:sta

Kohdistinkomennot Ý È Þ
Komento | Jakso
Siirrä kohdistinta # riviä ylöspäin | ESC [ # A
Siirrä kohdistinta # riviä alaspäin ESC [ # B
ESC [ # e
Siirrä kohdistinta # saraketta oikealle ESC [ # C
ESC [ # a
Siirrä kohdistinta # saraketta vasemmalle | ESC [ # D
Siirrä kohdistinta # riviä alaspäin; sarake=1 | ESC [ # E
Siirrä kohdistinta # riviä ylöspäin; sarake=1 | ESC [ # F
Tallenna kohdistimen sijainti ESC [ s
ESC 7
Palauta kohdistimen sijainti ESC [ u
ESC 8
Määritä kohdistimen sijainti - rivi ; sarake ESC [ # ; # H
ESC [ # ; # f
Siirrä kohdistin riville # | ESC [ # d
Siirrä kohdistinta # sarkainväliä taaksepäin | ESC [ # Z
Kohdistimen vakaa tila | ESC [ 33 h
Kohdistimen vilkkuva tila | ESC [ 33 l
Alaviivakohdistin | ESC [ 34 h
Ruutukohdistin | ESC [ 34 l
Kohdistin näkyvissä | ESC [ ? 25 h
Kohdistin piilotettu | ESC [ ? 25 l

Vierityskomennot Ý È Þ
Komento | Jakso
Vieritä yksi rivi ylöspäin | ESC S
Vieritä # riviä ylöspäin ESC [ # S
Vieritä yksi rivi alaspäin | ESC T
Vieritä # riviä alaspäin | ESC [ # T

Muokkauskomennot Ý È Þ
Komento | Jakso
Tyhjennä näyttö kohdistimesta alkaen | ESC [ J
Tyhjennä näyttö kohdistimeen asti | ESC [ 1 J
Tyhjennä näyttö | ESC [ 2 J
Tyhjennä rivi kohdistimesta alkaen | ESC [ K
Tyhjennä rivi kohdistimeen asti | ESC [ 1 K
Tyhjennä rivi | ESC [ 2 K
Lisää # riviä | ESC [ # L
Poista # riviä | ESC [ # M
Lisää # merkkiä | ESC [ # @
Poista # merkkiä | ESC [ # P

Attribuuttikomennot Ý È Þ
Komento | Jakso
Määritä edustaväri | ESC [ = # F
Määritä taustaväri | ESC [ = # G
Määritä edusta-/taustaväri | ESC [ 2 ; # ; # m
# | Väri | # | Väri
0 | musta | 8 | tummanharmaa
1 | sininen | 9 | vaaleansininen
2 | vihreä | 10 | vaaleanvihreä
3 | syaani | 11 | vaalea syaani
4 | punainen | 12 | vaaleanpunainen
5 | magenta | 13 | vaalea magenta
6 | keltainen | 14 | vaaleankeltainen
7 | harmaa | 15 | valkoinen
Näyttöattribuutin määrittäminen | ESC [ # m
# | Yleiset
0 | palauta kaikki attribuutit
1 | kirkas/lihavoitu edusta
3 | kirkas tausta
4 | alleviivaus
5 | vilkkuva
7 | käänteinen
8 | piilotettu syöte
10 | tyhjennä MSB (ASCII-grafiikka)
11 | siirry raakatulosteeseen (näytä kaikki koodit merkkeinä)
12 | määritä MSB (ASCII-grafiikka)
27 | palauta kaikki attribuutit (paitsi värit)
# | Määritä edustaväri
30 | musta
31 | punainen
32 | vihreä
33 | keltainen
34 | sininen
35 | magenta
36 | syaani
37 | harmaa
# | Määritä taustaväri
40 | musta
41 | punainen
42 | vihreä
43 | keltainen
44 | sininen
45 | magenta
46 | syaani
47 | harmaa

Raporttikomennot Ý È Þ
Komento | Isäntäpyynnöt | TelNet98:n vastaus
Määritä päätteen tunniste | ESC Z | ESC [ 98 t
Lähetä kohdistimen sijainti | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | kuten määritetty
Lähetä nayttö | ESC [ 2 i | näytön sisältö

Sekalaiset komennot Ý È Þ
Komento | Jakso

Funktionäppäimet
Tyhjennä kaikki otsikot | ESC [ z
Alusta funktionäppäin # otsikolla | ESC [ # z otsikko CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <VAIHTO>+F1 | - <VAIHTO>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<VAIHTO>+F1 | - <CTRL>+<VAIHTO>+F12

PC Scancode -tila
Scancode-tila käytössä | ESC [ ? 34 h
Scancode-tila pois käytöstä | ESC [ ? 34 l

Rivin lopun rivitys
Rivitys käytössä | ESC [ ? 7 h
Rivitys pois käytöstä | ESC [ ? 7 l

PC-komennot
Määritä istunnon nimi | ESC [ x nimi CR
Suorita paikallinen PC-ohjelma | ESC [ y komento CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC-merkit
Näytä PC-merkki # (=ascii) | ESC [ = # g

Näytön erotuskyky
# riviä, # saraketta | ESC [ = # ; # R
# riviä | ESC [ = # R
# saraketta | ESC [ = 0 ; # R

Tulostinkomennot Ý È Þ
Komento | Jakso
Tulosta näyttö | ESC [ i
Avaa paikallinen tulostin | ESC [ 5 i
Sulje paikallinen tulostin | ESC [ 4 i
Esimerkki paikallisesta tulostamisesta

TelNet98:n tulostusparannukset
Windows GDI suorittaa seuraavat jaksot, joten ne ovat tulostimesta riippumattomia:

Avaa paikallinen tulostin; Suunta: Pysty | ESC [ 5 ; 30 i
Avaa paikallinen tulostin; Suunta: Vaaka | ESC [ 5 ; 31 i
Avaa paikallinen tulostin; avaa Tulostimen asetukset -valintaikkuna | ESC [ 5 ; 32 i
EOL; aseta tulostussijainti nykyisen rivin kohtaan 0 | ESC [ 5 ; 2 i
LFBACK; rivinsiirto yksi rivi taaksepäin | ESC [ 5 ; 3 i
CPI, # merkkiä/tuuma | ESC [ 5 ; 6 ; # i
Aseta tulostussijainti sarakkeeseen # | ESC [ 5 ; 12 ; # i
Lihavointitila (#=1/0) | ESC [ 5 ; 14 ; # i
Palauta kaikki attribuutit oletusarvoiksi | ESC [ 5 ; 17 i
Alleviivaustila (#=1/0) | ESC [ 5 ; 18 ; # i
Yliviivaustila (#=1/0) | ESC [ 5 ; 19 ; # i
Alaindeksitila (#=1/0) | ESC [ 5 ; 20 ; # i
Yläindeksitila (#=1/0) | ESC [ 5 ; 21 ; # i
Kaksinkertaisen korkeuden tila (#=1/0) | ESC [ 5 ; 22 ; # i
Kaksinkertaisen leveyden tila (#=1/0) | ESC [ 5 ; 23 ; # i
Aseta sivun pituudeksi # riviä | ESC [ 5 ; 24 ; # i
LPI, # riviä/tuuma | ESC [ 5 ; 26 ; # i
Kursivointitila (#=1/0) | ESC [ 5 ; 27 ; # i
Reunus - Ylä- (#=rivien määrä) | ESC [ 5 ; 28 ; # i
Reunus - Vasen (#=merkkien määrä) | ESC [ 5 ; 29 ; # i

Hiirikomennot Ý È Þ
Komento | Jakso

Siirrä kohdistinta vasemmalle/oikealle
Käytössä | ESC [ 6 ; 1 ; 1 i
Pois käytöstä | ESC [ 6 ; 1 ; 0 i

Siirrä kohdistinta ylös/alas
Käytössä | ESC [ 6 ; 2 ; 1 i
Pois käytöstä | ESC [ 6 ; 2 ; 0 i

Ykköspainike
Pois käytöstä | ESC [ 6 ; 3 ; 0 i
Lähetä CR | ESC [ 6 ; 3 ; 1 i
Lähetä sijainti | ESC [ 6 ; 3 ; 2 i

Tulostuskomentosarjan malli Ý È Þ

Yksinkertainen shell-komentosarja, jolla voidaan tulostaa UNIX®-käyttöjärjestelmässä. Komentosarjaa voidaan käyttää komentona sekä suodattimena:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Tiedostonsiirto Ý È Þ

Tiedostojen siirtäminen telnet-protokollan kautta ei ole nopein tapa siirtää tiedostoja verkossa. Tiedostojen siirtäminen on kuitenkin helppoa vetämällä tiedoston hiirellä telnet-istuntoon, joka on avattu. TelNet98 tukee UUCODE-tietomuotoon perustuvaa binaarisiirtoa.

Isännän vaatimukset:
  • Komennot UUCODE-tietojen vastaanottamiseen ja lähettämiseen:
    uuencode ja uudecode, joita TelNet98 kutsuu, ovat useimmissa UNIX®-järjestelmissä. Jos niitä ei ole isäntäkoneessa - ohjelman lähdekoodi on saatavilla GNU Sharutils -paketissa, joka on ladattavissa Internetistä tai anonyymin FTP:n kautta.
    (kuten http://www.telnet98.com/gnu/)
  • Shell, joka voi vastaanottaa komentoja näppäimistöltä (komentokehote).
  • Riittävät käyttöoikeudet isäntäkoneessa kyseisten toimintojen suorittamiseen.

Tiedoston lataaminen isäntään
Ehdotetut vaiheet:
  1. Varmista, että edellä mainitut vaatimukset on täytetty.
  2. Valitse haluamasi tiedosto(t) Windowsin Resurssienhallinnassa
  3. Vedä tiedosto(t) hiirellä ja pudota telnet-istuntoon.

Tiedoston lataaminen
Ehdotetut vaiheet:
  1. Varmista, että edellä mainitut vaatimukset on täytetty.
  2. Luettele ladattavat tiedostot telnet-ikkunassa, kuten käyttämällä UNIXin® ls-komentoa.
  3. Valitse haluamasi tiedosto(t) luettelosta hiirellä ja kopioi nimet leikepöydälle.
  4. Valitse istunnon Muokkaa-valikosta komento Lataa tiedostoja ...
  5. Valitse näyttöön avautuvasta valintaikkunasta Liitä tiedostonimet leikepöydältä -painike.

terminfo Ý È Þ
Tätä ohjainta voidaan käyttää UNIX®-käyttöjärjestelmissä:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Tätä ohjainta voidaan käyttää UNIX®-käyttöjärjestelmissä:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Tietoja PC-scancode-koodista Ý È Þ

Toisin kuin vakiopäätteet, jotka lähettävät tietoja isäntään vain näppäintietomuodossa (merkit, jotka näkyvät näppäimessä), PC-scancode-toimintoa käyttävä pääte voi lähettää myös scancode-koodeja (yksilöllisiä arvoja, jotka liittyvät kunkin näppäimen painamiseen ja vapauttamiseen). Päätteen käyttäminen PC-scancode-tilassa antaa scancode-sovelluksen käyttää tarkempia näppäilyjä kuin pelkkä merkkitila mahdollistaisi. Jos määrität päätteen käyttämään merkkitilaa ja painat näppäintä A, pääte lähettää sovellukseen yksittäisen arvon A-kirjaimen ASCII-arvon). Jos kuitenkin määrität päätteen käyttämään scancode-tilaa ja painat näppäintä A, pääte lähettää yhden arvon, kun painat näppäintä, ja toisen arvon, kun vapautat näppäimen. Scancode-yhteensopiva sovellus kääntää nämä scancode-arvot isännässä olevan kartoituksen mukaisesti. Eric's TelNet98 lähettää scancode-koodit isäntään, kun scancode-tila on käytössä.

Esimerkki järjestelmän määrittämisestä käyttämään PC-scancode-koodia*)
  1. Lähetä terminfo.src isäntään ja käännä se tic-kääntäjällä:
    # tic terminfo.src
    Tämä luo terminaalityypin TERM=telnet98.

  2. In Määritä TelNet98-istunnon ominaisuuksissa päätetyypiksi telnet98

  3. Lisää komento, joka ottaa scancode-tilan käyttöön, polkuun /etc/profile (järjestelmänlaajuinen) tai tiedostoon .profile (vain omaan käyttöön):

    kuten
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) Testattu SCO® UNIX® -järjestelmässä; voi poiketa muissa järjestelmissä

© Friedrich Datentechnik GmbH. Kaikki oikeudet pidetään.


Référence Technique
Ÿ | Commandes de Curseur
Ÿ | Commandes de Déroulement
Ÿ | Commandes d'Edition
Ÿ | Commandes des Attributs de Texte
Ÿ | Commandes de Listing
Ÿ | Commandes Diverses
Ÿ | Commandes d'Impression
Ÿ | Commandes de Souris
Annexes
Ÿ | Exemple de Script d'impression
Ÿ | Transfert de Fichiers
Ÿ | le Pilote Terminfo
Ÿ | le Pilote Termcap
Ÿ | A propos du mode scancode
TelNet98 Web Site
ð | http://telnet98.com.fr/
ð | F A Q - Questions Souvent Posées
© Friedrich Datentechnik GmbH. Tous droits réservés.
Aide d' TelNet98

Commandes de Curseur Ý È Þ
Commande | Séquence
Monte le curseur de # lignes | ESC [ # A
Descend le curseur # lignes ESC [ # B
ESC [ # e
Avance le curseur de # colonnes ESC [ # C
ESC [ # a
Recule le curseur # colonnes | ESC [ # D
Descend le curseur de # lignes; positionne en col=1 | ESC [ # E
Monte le curseur de # lignes; positionne en col=1 | ESC [ # F
Sauve la position du curseur ESC [ s
ESC 7
Restaure la position du curseur ESC [ u
ESC 8
Le curseur en ligne ; colonne ESC [ # ; # H
ESC [ # ; # f
Positionne le curseur en ligne # | ESC [ # d
Recule le curseur de # tabulations | ESC [ # Z
curseur Stable | ESC [ 33 h
curseur Clignotant | ESC [ 33 l
curseur Souligné | ESC [ 34 h
curseur Bloc | ESC [ 34 l
curseur visible | ESC [ ? 25 h
curseur invisible | ESC [ ? 25 l

Commandes de Déroulement Ý È Þ
Commande | Séquence
Monte d'une ligne | ESC S
Monte de # lignes ESC [ # S
Descend d'une ligne | ESC T
Descend de # lignes | ESC [ # T

Commandes d'Edition Ý È Þ
Commande | Séquence
Effacer l'écran depuis le curseur | ESC [ J
Effacer l'écran jusqu'au curseur | ESC [ 1 J
Effacer l'écran | ESC [ 2 J
Effacer la ligne depuis le curseur | ESC [ K
Effacer la ligne jusqu'au curseur | ESC [ 1 K
Effacer la ligne | ESC [ 2 K
Insérer # lignes | ESC [ # L
Effacer # lignes | ESC [ # M
Insérer # caractères | ESC [ # @
Effacer # caractères | ESC [ # P

Commandes des Attributs de Texte Ý È Þ
Commande | Séquence
Colorier l'avant plan avec # | ESC [ = # F
Colorier l'arrière-plan avec # | ESC [ = # G
Colorier avant et arrière plans | ESC [ 2 ; # ; # m
# | Couleur | # | Couleur
0 | noir | 8 | gris foncé
1 | bleu | 9 | bleu clair
2 | vert | 10 | vert clair
3 | cyan | 11 | cyan clair
4 | rouge | 12 | rouge clair
5 | magenta | 13 | magenta clair
6 | jaune | 14 | jaune clair
7 | gris | 15 | blanc clair
Fixer un attribut d'écran | ESC [ # m
# | Général
0 | réinitialise tous les attributs
1 | bascule brillant/foncé en avant plan
3 | éclaircit l'arrière-plan
4 | souligné
5 | activation du clignotement
7 | mode inverse (négatif)
8 | saisie cachée (mots de passe)
10 | réinitialise MSB (graphiques ascii)
11 | bascule vers la sortie transparente (affiche tous les codes sous formes de caractères)
12 | active MSB (graphiques ascii)
27 | réinitialise tous les attributs (hormis les couleurs)
# | Colorier l'avant plan
30 | noir
31 | rouge
32 | vert
33 | jaune
34 | bleu
35 | magenta
36 | cyan
37 | gris
# | Colorier l'arrière plan
40 | noir
41 | rouge
42 | vert
43 | jaune
44 | bleu
45 | magenta
46 | cyan
47 | gris

Commandes de Listing Ý È Þ
Commande | Requête serveur | Réponse TelNet98
Identifier Terminal | ESC Z | ESC [ 98 t
Demande position curseur | ESC [ 6 n | ESC [ # ; # R
Réponse en retour | ENQ | voir paramètres
Envoyer Ecran | ESC [ 2 i | contenu de l'écran

Commandes Diverses Ý È Þ
Commande | Séquence

Touches de fonction
Effacer toutes les touches | ESC [ z
Initialiser la touche # avec Contenu | ESC [ # z Cont RC
#1 | - #12 = F1 | - F12
#13 | - #24 = <MAJ>+F1 | - <MAJ>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<MAJ>+F1 | - <CTRL>+<MAJ>+F12

Mode Scancode sur PC
Active le mode scancode | ESC [ ? 34 h
Désactive le mode scancode | ESC [ ? 34 l

Retour à la ligne
Retour à la ligne automatique | ESC [ ? 7 h
Pas de retour à la ligne | ESC [ ? 7 l

Commandes PC
Nom de la Session | ESC [ x Nom RC
Exécuter un programme local sue le PC | ESC [ y Cmd RC
ShellExec | ESC [ yShellExec SP shlobj RC

Caractères PC
Affiche le caractère PC # (=Ascii) | ESC [ = # g

Espace du Ecran
# Lignes, # Colonnes | ESC [ = # ; # R
# Lignes | ESC [ = # R
# Colonnes | ESC [ = 0 ; # R

Commandes D'imprimante Ý È Þ
Commande | Séquence
Copie d'écran | ESC [ i
Ouvrir l'imprimante locale | ESC [ 5 i
Fermer l'imprimante locale | ESC [ 4 i
Exemples d'utilisation de l'impression locale

Améliorations TelNet98
Ces séquences sont résolues par le GDI Windows et sont donc totalement indépendantes des caractéristiques matérielles des imprimantes:

Ouvrir l'imprimante locale; Orientation: Portrait | ESC [ 5 ; 30 i
Ouvrir l'imprimante locale; Orientation: Paysage | ESC [ 5 ; 31 i
Ouvrir l'imprimante locale + Configuration de l'impression | ESC [ 5 ; 32 i
Repositionne la tête d'impression en colonne 0 sur la même ligne | ESC [ 5 ; 2 i
LFBACK; remonte d'1 ligne | ESC [ 5 ; 3 i
CPI, # caractères par pouce | ESC [ 5 ; 6 ; # i
Positionne la tête d'impression en colonne # | ESC [ 5 ; 12 ; # i
bascule Renforcé (#=1/0) | ESC [ 5 ; 14 ; # i
Réinitialise tous les attributs | ESC [ 5 ; 17 i
bascule Soulignement (#=1/0) | ESC [ 5 ; 18 ; # i
bascule Barré (#=1/0) | ESC [ 5 ; 19 ; # i
bascule Subscript (#=1/0) | ESC [ 5 ; 20 ; # i
bascule Superscript (#=1/0) | ESC [ 5 ; 21 ; # i
bascule Double Hauteur (#=1/0) | ESC [ 5 ; 22 ; # i
bascule Double Largeur (#=1/0) | ESC [ 5 ; 23 ; # i
Fixe la Hauteur de Page à # lignes | ESC [ 5 ; 24 ; # i
LPI, # lignes par pouce | ESC [ 5 ; 26 ; # i
bascule Italique (#=1/0) | ESC [ 5 ; 27 ; # i
Marge - Haut (#=lignes) | ESC [ 5 ; 28 ; # i
Marge - Gauche (#=caractères) | ESC [ 5 ; 29 ; # i

Commandes de Souris Ý È Þ
Commande | Séquence

Avance/recule le curseur
Active | ESC [ 6 ; 1 ; 1 i
Désactive | ESC [ 6 ; 1 ; 0 i

Monte/descend le curseur
Active | ESC [ 6 ; 2 ; 1 i
Désactive | ESC [ 6 ; 2 ; 0 i

Bouton gauche
Désactive | ESC [ 6 ; 3 ; 0 i
Envoyer RC | ESC [ 6 ; 3 ; 1 i
Envoyer position | ESC [ 6 ; 3 ; 2 i

Exemple de Script d'Impression Ý È Þ

Simple script de shell pour imprimer sur les systèmes UNIX®; Ce script peut être utilisé comme commande ou filtre:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Transfert de Fichiers Ý È Þ

Transférer des fichiers avec le protocole Telnet n’est pas la méthode la plus rapide. Toutefois, cela augmente le confort lors de certaines manipulations, utilisant une connexion déjà établie et en déplaçant les fichiers avec la souris. TelNet98 supporte les transferts binaires, basés sur le format de données UUCODE.

Environnement compatible avec les opérations de transfert:
  • Les Commandes pour recevoir et émettre des données uuencodées:
    uuencode et uudecode, qui sont appelées par TelNet98, sont déjà disponibles sur la plupart des systèmes UNIX®. Si elles sont absentes de l’hôte, les sources de ces programmes sont dans le package GNU Sharutils, qui peut être téléchargé du Web ou par FTP anonyme.
    (par exemple http://telnet98.com.fr/gnu/)
  • Un shell, prêt à traiter des commandes au clavier.
  • Les droits sur l’hôte pour exécuter ces commandes.

Téléchargement vers l’hôte
Etapes suggérées:
  1. Assurez vous de la compatibilité de l’hôte avec ces opérations
  2. Sélectionner un ou plusieurs fichiers dans l’explorateur Windows
  3. Déplacez la sélection avec la souris pour les lâcher dans la fenêtre telnet

Téléchargement de l’hôte
Etapes suggérées:
  1. Assurez vous de la compatibilité de l’hôte avec ces opérations
  2. Afficher sur l’écran telnet les fichiers à télécharger, par exemple avec la commande UNIX® ls
  3. Sélectionnez un ou plusieurs fichiers dans la liste avec la souris et copiez les dans le presse-papiers
  4. Allez au menu édition -> 'Télécharger des fichiers de l’hôte'
  5. Pressez le bouton 'Coller des fichiers du presse-papiers'

terminfo Ý È Þ
Ce driver peut être utilisé sur les SE UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Ce driver peut être utilisé sur les SE UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

A propos du mode scancode Ý È Þ

Contrairement aux terminaux standards qui envoyent les codes affichés des clés touchées, le système de gestion du clavier des PC peut relever des informations plus fines. Il signale par exemple les débuts et fins de pression sur les touches ainsi que la manipulation pas à pas de touches de contrôle. Une application sachant exploiter ce mode permettra une plus grande variété de manipulation. A titre d'exemple, si vous pressez la lettre A sur un terminal classique, il enverra une valeur unique représentant A ou a selon l'état courant de la touche majuscule/minuscule. Mais si vous faites de même sur un terminal gérant le mode scancode, il enverra un code signalant la pression sur la touche marquée A puis un autre code lors du relâchement. Ces codes sont prédéterminés et stockés dans un fichier réservé. Eric's TelNet98 utilise le mode scancode, lorsque ce mode est activé.

Configuration de votre système pour utiliser le mode scancode*)
  1. Téléchargez terminfo.src vers le serveur. Compilez le avec tic:
    # tic terminfo.src
    Ceci gérérera un TERM=telnet98 termtype.

  2. Dans la boite de dialogue Ouvrir de TelNet98, précisez telnet98 dans la zone termtype

  3. Ajoutez une commande à votre /etc/profile (pour usage général) ou à votre .profile (pour usage privé uniquement) pour activer le mode scancode:

    Exemple:
    # active le mode scancode
    # quand c'est possible
    if tput smsc
    then
    # active le mode scancode sur le serveur
    stty isscancode xscancode
    fi
*) testé sur SCO® Unix®; Pourrait être complètement différents sur d'autres systèmes.

© Friedrich Datentechnik GmbH. Tous droits réservés.


Technische Referenz
Ÿ | Cursor Steuer-Sequenzen
Ÿ | Scroll Steuer-Sequenzen
Ÿ | Editier Steuer-Sequenzen
Ÿ | Attributierungs Steuer-Sequenzen
Ÿ | Report Steuer-Sequenzen
Ÿ | Sonstige Steuer-Sequenzen
Ÿ | Drucker Steuer-Sequenzen
Ÿ | Maus Steuer-Sequenzen
Anhang
Ÿ | Print-Script Beispiel
Ÿ | Filetransfer
Ÿ | terminfo-Treiber
Ÿ | termcap-Treiber
Ÿ | PC-Scancode Modus
Die TelNet98 Web Site
ð | http://www.telnet98.de/
ð | F A Q - Häufig gestellte Fragen
© Friedrich Datentechnik GmbH. Alle Rechte vorbehalten.
Info zu TelNet98

Cursor-Befehle Ý È Þ
Befehl | Sequenz
Cursor # Zeilen nach oben | ESC [ # A
Cursor # Zeilen nach unten ESC [ # B
ESC [ # e
Cursor # Spalten nach rechts ESC [ # C
ESC [ # a
Cursor # Spalten nach links | ESC [ # D
Cursor # Zeilen nach unten; Spalte=1 | ESC [ # E
Cursor # Zeilen nach oben; Spalte=1 | ESC [ # F
Cursor Position merken ESC [ s
ESC 7
Zurück zu gemerkter Position ESC [ u
ESC 8
Cursor auf Position Zeile ; Spalte ESC [ # ; # H
ESC [ # ; # f
Setze Cursor in Zeile # | ESC [ # d
Cursor # TABS zurück | ESC [ # Z
Cursor in permanent Modus | ESC [ 33 h
Cursor in blinken Modus | ESC [ 33 l
Unterstrich Cursor | ESC [ 34 h
Block Cursor | ESC [ 34 l
Cursor sichtbar | ESC [ ? 25 h
Cursor unsichtbar | ESC [ ? 25 l

Scroll-Befehle Ý È Þ
Befehl | Sequenz
Rolle eine Zeile nach oben | ESC S
Rolle # Zeilen nach oben ESC [ # S
Rolle eine Zeile nach unten | ESC T
Rolle # Zeilen nach unten | ESC [ # T

Editier-Befehle Ý È Þ
Befehl | Sequenz
Bildschirm ab Cursor löschen | ESC [ J
Bildschirm bis Cursor löschen | ESC [ 1 J
Bildschirm löschen | ESC [ 2 J
Zeile ab Cursor löschen | ESC [ K
Zeile bis Cursor löschen | ESC [ 1 K
Zeile löschen | ESC [ 2 K
# Zeilen einfügen | ESC [ # L
# Zeilen löschen | ESC [ # M
# Zeichen einfügen | ESC [ # @
# Zeichen löschen | ESC [ # P

Attributierungs-Befehle Ý È Þ
Befehl | Sequenz
Vordergrundfarbe # setzen | ESC [ = # F
Hintergrundfarbe # setzen | ESC [ = # G
Setze Vorder-/ Hintergrundfarbe | ESC [ 2 ; # ; # m
# | Farbe | # | Farbe
0 | schwarz | 8 | dunkel-grau
1 | blau | 9 | hell-blau
2 | grün | 10 | hell-grün
3 | zyan | 11 | hell-zyan
4 | rot | 12 | hell-rot
5 | violett | 13 | hell-violett
6 | gelb | 14 | hell-gelb
7 | grau | 15 | weiß
Bildschirmattribut setzen | ESC [ # m
# | Allgemein
0 | alle Attribute zurücksetzen
1 | erhellter Vordergrund
3 | erhellter Hintergrund
4 | unterstreichen
5 | blinken
7 | invers
8 | verdeckte Eingabe
10 | MSB löschen (Ascii Grafik)
11 | auf direkte Ausgabe umschalten (auch Steuerzeichen darstellen)
12 | MSB setzen (Ascii Grafik)
27 | alle Attribute zurücksetzen (ausgenommen Farben)
# | Vordergrundfarbe
30 | schwarz
31 | rot
32 | grün
33 | gelb
34 | blau
35 | violett
36 | zyan
37 | grau
# | Hintergrundfarbe
40 | schwarz
41 | rot
42 | grün
43 | gelb
44 | blau
45 | violett
46 | zyan
47 | grau

Report-Befehle Ý È Þ
Befehl | Host Anfrage | Antwort von TelNet98
Identifiziere Terminal | ESC Z | ESC [ 98 t
Sende Cursor Position | ESC [ 6 n | ESC [ # ; # R
Sende Antwort-Text | ENQ | wie eingestellt
Sende Bildschirm | ESC [ 2 i | Bildschirm Inhalt

Sonstige Befehle Ý È Þ
Befehl | Sequenz

Funktionstasten
Alle Labels löschen | ESC [ z
Initialisiere Funktionstaste # mit Text | ESC [ # z Text CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <GROSS>+F1 | - <GROSS>+F12
#25 | - #36 = <STRG>+F1 | - <STRG>+F12
#37 | - #48 = <STRG>+<GROSS>+F1 | - <STRG>+<GROSS>+F12

PC Scancode Modus
Scancode Modus aktivieren | ESC [ ? 34 h
Scancode Modus deaktivieren | ESC [ ? 34 l

Zeilenumbruch
Zeilenumbruch ein | ESC [ ? 7 h
Zeilenumbruch aus | ESC [ ? 7 l

PC Befehle
Sitzungsnamen setzen | ESC [ x Name CR
Lokales PC-Programm ausführen | ESC [ y Befehl CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC Zeichen
Gebe PC Zeichen # (=Ascii) aus | ESC [ = # g

Bildschirmauflösung
# Zeilen, # Spalten | ESC [ = # ; # R
# Zeilen | ESC [ = # R
# Spalten | ESC [ = 0 ; # R

Drucker-Befehle Ý È Þ
Befehl | Sequenz
Hardcopy | ESC [ i
Lokalen Drucker öffnen | ESC [ 5 i
Lokalen Drucker schließen | ESC [ 4 i
Beispiel zur Verwendung des lokalen Druckers

TelNet98 spezifische Drucker Erweiterungen
Die folgenden Sequenzen werden durch Windows GDI aufgelöst und sind daher unabhängig von einer bestimmten Drucker Hardware:

Drucker wählen | ESC [ = p Name CR
Lokalen Drucker öffnen; Ausrichtung: Hochformat | ESC [ 5 ; 30 i
Lokalen Drucker öffnen; Ausrichtung: Querformat | ESC [ 5 ; 31 i
Lokalen Drucker öffnen; Druckereinrichtung anzeigen | ESC [ 5 ; 32 i
Drucker auf Position 0 in der aktuellen Zeile | ESC [ 5 ; 2 i
Linefeed eine Zeile zurück | ESC [ 5 ; 3 i
CPI, # Zeichen pro Zoll | ESC [ 5 ; 6 ; # i
Druckposition auf Spalte # | ESC [ 5 ; 12 ; # i
Fettdruck ein/aus (#=1/0) | ESC [ 5 ; 14 ; # i
Alle Attribute zurücksetzen | ESC [ 5 ; 17 i
Unterstreichen ein/aus (#=1/0) | ESC [ 5 ; 18 ; # i
Durchgestrichen ein/aus (#=1/0) | ESC [ 5 ; 19 ; # i
Tiefgestellt ein/aus (#=1/0) | ESC [ 5 ; 20 ; # i
Hochgestellt ein/aus (#=1/0) | ESC [ 5 ; 21 ; # i
Doppelte Höhe ein/aus (#=1/0) | ESC [ 5 ; 22 ; # i
Doppelte Breite ein/aus (#=1/0) | ESC [ 5 ; 23 ; # i
Seitenlänge auf # Zeilen setzen | ESC [ 5 ; 24 ; # i
LPI, # Zeilen pro Zoll | ESC [ 5 ; 26 ; # i
Kursivdruck ein/aus (#=1/0) | ESC [ 5 ; 27 ; # i
Seitenrand - Oben (#=Zeilen) | ESC [ 5 ; 28 ; # i
Seitenrand - Links (#=Zeichen) | ESC [ 5 ; 29 ; # i

Maus-Befehle Ý È Þ
Befehl | Sequenz

Bewege Cursor links/rechts
Aktiviert | ESC [ 6 ; 1 ; 1 i
Deaktiviert | ESC [ 6 ; 1 ; 0 i

Bewege Cursor auf/ab
Aktiviert | ESC [ 6 ; 2 ; 1 i
Deaktiviert | ESC [ 6 ; 2 ; 0 i

Linke Taste
Deaktiviert | ESC [ 6 ; 3 ; 0 i
Sende CR | ESC [ 6 ; 3 ; 1 i
Sende Position | ESC [ 6 ; 3 ; 2 i

Print-Script Beispiel Ý È Þ

Muster Shell-Script zur Druckausgabe unter UNIX® Betriebssystemen; Das Script kann sowohl als Kommando als auch als Filter verwendet werden:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Filetransfer Ý È Þ

Dateien per Telnet Protokoll zu übertragen ist sicherlich nicht die schnellste Methode, Daten innerhalb eines Netzwerkes zu transportieren. Allerdings ergibt sich ein gewisser Komfort, wenn man Dateien dadurch übertragen kann, indem man Sie einfach mit der Maus in eine Telnet-Sitzung zieht, die bereits geöffnet ist. TelNet98 unterstützt binäre Datenübertragung, basierend auf dem UUCODE Datenformat.

Voraussetzungen auf dem Host:
  • Befehle zum Empfangen und Senden von uucodierten Daten:
    uuencode und uudecode, die von TelNet98 aufgerufen werden, sind auf den meisten UNIX® Systemen bereits vorhanden. Sollten diese auf Ihrem Host fehlen - die Quellprogramme sind verfügbar im GNU-Sharutils-Paket, das aus dem Internet oder über Anonymous FTP heruntergeladen werden kann.
    (z.B. http://www.telnet98.de/gnu/)
  • Eine befehlsbereite Shell (Command Prompt)
  • Ausreichende Rechte auf dem Host-System, um diese Operationen durchführen zu können

Dateien heraufladen - Upload
Vorgeschlagene Schritte:
  1. Stellen Sie sicher, dass die oben genannten Voraussetzungen erfüllt sind
  2. Markieren Sie eine oder mehrere Dateien im Windows Explorer
  3. Ziehen Sie die Datei(en) mit der Maus über Ihre Telnet-Sitzung und lassen Sie sie dort los

Dateien herunterladen - Download
Vorgeschlagene Schritte:
  1. Stellen Sie sicher, dass die oben genannten Voraussetzungen erfüllt sind
  2. Listen Sie die zu übertragenden Dateien auf Ihrem Telnet Bildschirm, z.B. mit dem UNIX® ls Befehl
  3. Markieren Sie eine oder mehrere von den aufgelisteten Dateien mit der Maus und kopieren Sie deren Namen in die Zwischenablage
  4. Rufen Sie aus dem Sitzungsmenü den Eintrag 'Bearbeiten' -> 'Dateien herunterladen' auf
  5. In dem nun erscheinenden Dialog drücken Sie den Button 'Dateinamen aus Zwischenablage einfügen'

terminfo Ý È Þ
Dieser Treiber kann unter UNIX® Systemen zur Bildschirmsteuerung verwendet werden:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Dieser Treiber kann unter UNIX® Systemen zur Bildschirmsteuerung verwendet werden:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

PC Scancode Modus Ý È Þ

Anders als bei Standard-Terminals, die die Informationen an den Host in Form von ASCII-Codes weitergeben, kann ein scancode-fähiges Terminal die Codes der PC-Tastatur (eindeutig zugeordnete Werte beim Drücken als auch beim Loslassen der einzelnen Tasten) an den Host senden. Wird ein Terminal im Scancode-Modus betrieben, ist es einer darauf abgestimmten Anwendung möglich, viel differenzierter mit der Tastatur umzugehen, als dies bei einer zeichenorientierten Steuerung möglich wäre. Wenn Sie beispielsweise bei zeichenorientierter Steuerung die Taste 'A' drücken, sendet das Terminal einen einzelnen Wert (den ASCII-Wert von 'A'). Wenn Sie die gleiche Taste im Scancode-Modus betätigen, wird sowohl beim Drücken, als auch beim Loslassen der Taste jeweils ein unterschiedlicher Code erzeugt. Eric's TelNet98 sendet Scancodes an den Host, wenn der Scancode-Modus aktiv ist.

Konfigurationsbeispiel zur Aktivierung von PC-Scancode*)
  1. Übertragen Sie die Datei terminfo.src auf Ihren Host und compilieren Sie sie dort mit dem tic Compiler:
    # tic terminfo.src
    Damit erzeugen Sie einen TERM=telnet98 Terminal Typen.

  2. Tragen Sie in TelNet98 im TERM= Feld den Wert telnet98 ein.

  3. Fügen Sie nun auf dem Host in Ihrer /etc/profile (für eine systemweite Änderung) oder in Ihrer .profile (für die Änderung bei einem einzelnen Benutzer) folgende Kommandos ein:

    Beispiel:
    # Scancode-Modus am Terminal
    # aktivieren, falls verfuegbar
    if tput smsc
    then
    # Scancode-Modus auf dem Host aktivieren
    stty isscancode xscancode
    fi
*) getestet auf einem SCO® UNIX® Rechner; kann bei anderen Systemen mitunter abweichen

© Friedrich Datentechnik GmbH. Alle Rechte vorbehalten.


Riferimenti tecnici
Ÿ | Sequenze di comando di cursore
Ÿ | Sequenze di comando di scorrimento
Ÿ | Sequenze di comando di Edit
Ÿ | Sequenze di comando di Attributo
Ÿ | Sequenze di comando di Report
Ÿ | Altre sequenze di comando
Ÿ | Sequenze di comando di stampa
Ÿ | Sequenze di comando di mouse
Appendice
Ÿ | Print Script (esempio)
Ÿ | Trasferimento di file
Ÿ | Driver Terminfo
Ÿ | Driver Termcap
Ÿ | PC-scancode
TelNet98 Web Site
ð | http://www.telnet98.com/
ð | F A Q - Frequently Asked Questions
© Friedrich Datentechnik GmbH. Tutti diritti riservati.
Info su TelNet98

Comandi di cursore Ý È Þ
Comando | Sequenza
Sposta il cursore # righe in su | ESC [ # A
Sposta il cursore # righe in giù ESC [ # B
ESC [ # e
Sposta il cursore # colonne a destra ESC [ # C
ESC [ # a
Sposta il cursore # colonne a sinistra | ESC [ # D
Sposta il cursore # righe in giù; col=1 | ESC [ # E
Sposta il cursore # righe in su; col=1 | ESC [ # F
Salva la posizione del cursore ESC [ s
ESC 7
Ripristina posizione del cursore ESC [ u
ESC 8
Sposta il cursore alla riga ; colonna ESC [ # ; # H
ESC [ # ; # f
Sposta il cursore alla riga # | ESC [ # d
Sposta il cursore # tabulatori indietro | ESC [ # Z
Cursore fisso | ESC [ 33 h
Cursore lampeggiante | ESC [ 33 l
Cursore a trattino | ESC [ 34 h
Cursore quadrato | ESC [ 34 l
Cursore visibile | ESC [ ? 25 h
Cursore nascosto | ESC [ ? 25 l

Comandi di scorrimento Ý È Þ
Comando | Sequenza
Scorri una riga in su | ESC S
Scorri # righe in su ESC [ # S
Scorri una riga in giù | ESC T
Scorri # righe in giù | ESC [ # T

Comandi di Edit Ý È Þ
Comando | Sequenza
Cancella dal cursore | ESC [ J
Cancella fino al cursore | ESC [ 1 J
Cancella tutto | ESC [ 2 J
Cancella riga dal cursore | ESC [ K
Cancella riga fino al cursore | ESC [ 1 K
Cancella riga | ESC [ 2 K
Inserisci # righe | ESC [ # L
Cancella # righe | ESC [ # M
Inserisci # caratteri | ESC [ # @
Cancella # caratteri | ESC [ # P

Comandi di Attributo Ý È Þ
Comando | Sequenza
Imposta colore di primo piano a # | ESC [ = # F
Imposta colore di sfondo a # | ESC [ = # G
Imposta colore di primo piano/sfondo | ESC [ 2 ; # ; # m
# | Colore | # | Colore
0 | nero | 8 | grigio scuro
1 | azzurro | 9 | azzurro chiaro
2 | verde | 10 | verde chiaro
3 | ciano | 11 | ciano chiaro
4 | rosso | 12 | rosso chiaro
5 | magenta | 13 | magenta chiaro
6 | giallo | 14 | giallo chiaro
7 | grigio | 15 | bianco
Imposta caratteristiche della schermata | ESC [ # m
# | Generale
0 | resetta tutti gli attributi
1 | primo piano chiaro/grassetto
3 | sfondo chiaro
4 | sottolinea
5 | lampeggia
7 | inverti
8 | input nascosto
10 | resetta MSB
11 | visualizza tutti codici come carattere
12 | imposta MSB
27 | resetta tutti gli attributi (ecetto colori)
# | Imposta colore di primo piano
30 | nero
31 | rosso
32 | verde
33 | giallo
34 | azzurro
35 | magenta
36 | ciano
37 | grigio
# | Imposta colore dello sfondo
40 | nero
41 | rosso
42 | verde
43 | giallo
44 | azzurro
45 | magenta
46 | ciano
47 | grigio

Comandi di Report Ý È Þ
Comando | Host Richiesta | TelNet98 Risposta
Identifica Terminale | ESC Z | ESC [ 98 t
Trasmetti posizione cursore | ESC [ 6 n | ESC [ # ; # R
Risposta | ENQ | come impostato
Trasmetti schermata | ESC [ 2 i | Contenuto schermata

Altri comandi Ý È Þ
Comando | Sequenza

Tasti di Funzione
Azzera tutte le descrizioni | ESC [ z
Inizializza tasto di funzione # con descrizione | ESC [ # z descrizione CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <MAIUSC>+F1 | - <MAIUSC>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<MAIUSC>+F1 | - <CTRL>+<MAIUSC>+F12

PC-Scancode
Attiva | ESC [ ? 34 h
Disattiva | ESC [ ? 34 l

A capo automatico
Attiva | ESC [ ? 7 h
Disattiva | ESC [ ? 7 l

PC-Comandi
Imposta nome sessione | ESC [ x nome CR
Esegui programma locale del PC | ESC [ y programma CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC-Caratteri
Visualizza carattere PC # (=ascii) | ESC [ = # g

Risoluzione schermata
# Righe, # Colonne | ESC [ = # ; # R
# Righe | ESC [ = # R
# Colonne | ESC [ = 0 ; # R

Comandi Stampante Ý È Þ
Comando | Sequenza
Stampa schermata | ESC [ i
Apri stampante locale | ESC [ 5 i
Chiudi stampante locale | ESC [ 4 i
Esempio come utilizzare una stampante locale

TelNet98 modalità particolari per la stampante
Le sequenze seguenti vengono effettuate da Windows GDI e non sono particolari di una stampante specifica:

Apri stampante locale; Orientamento: Verticale | ESC [ 5 ; 30 i
Apri stampante locale; Orientamento: Orizzontale | ESC [ 5 ; 31 i
Apri stampante locale + Imposta stampante | ESC [ 5 ; 32 i
EOL; imposta la posizione di stampa alla posizione 0 nella riga corrente | ESC [ 5 ; 2 i
LFBACK; Una riga in su | ESC [ 5 ; 3 i
CPI, # caratteri per pollici | ESC [ 5 ; 6 ; # i
Posiziona stampante alla colonna # | ESC [ 5 ; 12 ; # i
Grassetto attiva/disattiva (#=1/0) | ESC [ 5 ; 14 ; # i
Resetta tutti gli attributi | ESC [ 5 ; 17 i
Sottolineato attiva/disattiva (#=1/0) | ESC [ 5 ; 18 ; # i
Barrato attiva/disattiva (#=1/0) | ESC [ 5 ; 19 ; # i
Pedice attiva/disattiva (#=1/0) | ESC [ 5 ; 20 ; # i
Apice attiva/disattiva (#=1/0) | ESC [ 5 ; 21 ; # i
Altezza doppia attiva/disattiva (#=1/0) | ESC [ 5 ; 22 ; # i
Larghezza doppia attiva/disattiva (#=1/0) | ESC [ 5 ; 23 ; # i
Imposta lunghezza pagina a # righe | ESC [ 5 ; 24 ; # i
LPI, # righe per pollici | ESC [ 5 ; 26 ; # i
Corsivo attiva/disattiva (#=1/0) | ESC [ 5 ; 27 ; # i
Margini - Alto (#=righe) | ESC [ 5 ; 28 ; # i
Margini - Sinistra (#=caratteri) | ESC [ 5 ; 29 ; # i

Comandi di mouse Ý È Þ
Comando | Sequenza

Sposta il cursore a destra/sinistra
Attiva | ESC [ 6 ; 1 ; 1 i
Disattiva | ESC [ 6 ; 1 ; 0 i

Sposta il cursore in su/giù
Attiva | ESC [ 6 ; 2 ; 1 i
Disattiva | ESC [ 6 ; 2 ; 0 i

Pulsante sinistro
Disattiva | ESC [ 6 ; 3 ; 0 i
Trasmetti CR | ESC [ 6 ; 3 ; 1 i
Trasmetti posizione | ESC [ 6 ; 3 ; 2 i

Print Script (esempio) Ý È Þ

Semplice shell script per stampare sotto UNIX®; lo script può essere utilizzato come comando o come filtro:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Trasferimento di file Ý È Þ

Transferire dati con il protocollo telnet non è il metodo più veloce per trasferire dati in una rete. Ma nonostante tutto migliora l'operatività perché è possibile trasferire un file trascinando questo con il mouse nella sessione telnet aperta. TelNet98 supporta il trasferimento di file binari secondo il formato UUCODE.

Requisiti del host:
  • Comandi per ricevere e trasmettere dati formato UUCODE:
    uuencode e uudecode, che viene attivata da TelNet98, sono normalmente già presente in tutti sistemi UNIX®.
    Se questi dovessero mancare sul tuo host, le sorgenti di programma sono disponibili in pacchetti Shareutils di GNU.
    Questi possono essere scaricati facilmente da internet.
    (per esempio http://www.telnet98.com/gnu/)
  • La shell che è pronta per ricevere comandi dalla tastiera (Prompt di comando)
  • Diritti sul host che permettono le operazioni da effettuare

Invia file
Passi suggeriti:
  1. Accertarsi che i requisiti di sopra siano mantenuti
  2. Selezionare uno o piu file da Gestione risorse di Windows
  3. Trascinare i file selezionati nella tua sessione telnet

Ricevi file
Passi suggeriti:
  1. Accertarsi che i requisiti di sopra siano mantenuti
  2. Elencare i file da scaricare nella tua schermata telnet per esempio utilizzando il comando UNIX® ls
  3. Selezionare uno o più file di quelli elencati con il mouse e copiare questi negli appunti di Windows
  4. Scegliere 'Modifica' -> 'Ricevi file ...' dal menu Sessione
  5. E premere nel dialogo il pulsante 'Incolla nome dei file dagli appunti'

terminfo Ý È Þ
Questo driver può essere utilizzato sotto UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Questo driver può essere utilizzato sotto UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

PC-scancode Ý È Þ

Diversamente dai terminali standard, che possono trasmettere informazioni al' host solo in forma di valori Keytop (il carattere impresso sul tasto), il terminale con funzione PC-scancode può inviare anche scancodes che presentano valori associati alla pressione e al rilascio del tasto. Utilizzando il terminale in modalità PC-scancode è possibile utilizzare con una applicazione scancode compatibile molti più comandi da tastiera rispetto alla modalità carattere. Per esempio, premendo con il terminale in modalità carattere il tasto 'A', il terminale invierà un singolo valore (valore ASCII del carattere 'A') alla applicazione. Con il terminale in modalità scancode premendo il tasto 'A' il terminale invierà un valore alla pressione del tasto e un altro valore al rilascio del tasto. L'applicazione compatibile scancode traduce queste informazioni in funzione alla tabella di caratteri residente sul host. Eric's TelNet98 trasmette scancodes al host quando questa funzione è abilitata.

Passi suggeriti per configurare il tuo sistema per la modalità PC-scancode*)
  1. Trasferire terminfo.src al tuo host e compilare utilizzando il compilatore tic:
    # tic terminfo.src
    Con questo verrà creato TERM=telnet98 termtype.

  2. Impostare in TelNet98 nel dialogo Apri imposta termtype per telnet98

  3. Aggiungere un comando per abilitare scanmode per il profilo /etc/profile o per il tuo profilo personale .profile:

    per esempio:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) provato su sistemi SCO® UNIX®; potrebbe essere diverso per altri sistemi

© Friedrich Datentechnik GmbH. Tutti diritti riservati.


Teknisk referanse
Ÿ | Markør-sekvenser
Ÿ | Scrolle-sekvenser
Ÿ | Redigeringssekvenser
Ÿ | Attribute-sekvenser
Ÿ | Rapport-sekvenser
Ÿ | Diverse sekvenser
Ÿ | Utskriftssekvenser
Ÿ | Mus-sekvenser
Eksempler
Ÿ | Script for utskrift
Ÿ | Filoverføring
Ÿ | Terminfo driver
Ÿ | Termcap driver
Ÿ | Litt om PC-scancode
TelNet98 Web Site
ð | http://www.telnet98.com/
ð | F A Q - Frequently Asked Questions
© Friedrich Datentechnik GmbH. Alle rettigheter reservert.
Info om TelNet98

Markør kommandoer Ý È Þ
Kommando | Sekvens
Flytt markør # linjer opp | ESC [ # A
Flytt markør # linjer ned ESC [ # B
ESC [ # e
Flytt markør # kolonner til høyre ESC [ # C
ESC [ # a
Flytt markør # kolonner til venstre | ESC [ # D
Flytt markør # linjer ned; kol=1 | ESC [ # E
Flytt markør # linjer opp; kol=1 | ESC [ # F
Lagre markør posisjon ESC [ s
ESC 7
Tilbakestill markør-posisjon ESC [ u
ESC 8
Sett markør-posisjon linje ; kolonne ESC [ # ; # H
ESC [ # ; # f
Flytt markør til linje # | ESC [ # d
Flytt markør # TAB-områder tilbake | ESC [ # Z
Markør - ikke blink | ESC [ 33 h
Markør - blink | ESC [ 33 l
Understreking-markør | ESC [ 34 h
Blokk markør | ESC [ 34 l
Synlig markør | ESC [ ? 25 h
Usynlig markør | ESC [ ? 25 l

Scroll kommandoer Ý È Þ
Kommando | Sekvens
Scroll en linje opp | ESC S
Scroll # linjer opp ESC [ # S
Scroll en linje ned | ESC T
Scroll # linjer ned | ESC [ # T

Redigering Ý È Þ
Kommando | Sekvens
Tøm skjerm fra markør | ESC [ J
Tøm skjerm til markør | ESC [ 1 J
Tøm skjerm | ESC [ 2 J
Tøm linje fra markør | ESC [ K
Tøm linje til markør | ESC [ 1 K
Tøm linje | ESC [ 2 K
Legg til # linjer | ESC [ # L
Slett # linjer | ESC [ # M
Legg til # tegn | ESC [ # @
Slett # tegn | ESC [ # P

Attribute Ý È Þ
Kommando | Sekvens
Sett tekstfarge til # | ESC [ = # F
Sett bakgrunnsfarge til # | ESC [ = # G
Sett tekst/bakgrunn til | ESC [ 2 ; # ; # m
# | Farge | # | Farge
0 | svart | 8 | mørk grå
1 | blå | 9 | lys blå
2 | grønn | 10 | lys grønn
3 | cyan | 11 | lys cyan
4 | rød | 12 | lys rød
5 | magenta | 13 | lys magenta
6 | gul | 14 | lys gul
7 | grå | 15 | hvitt
Skjerm attribute | ESC [ # m
# | Generelt
0 | nullstill alle attributer
1 | lys/fet tekst
3 | lys bakgrunn
4 | understreking
5 | blink
7 | motsatt
8 | skjult inntasting
10 | nullstill MSB (ascii grafikk)
11 | bytt til direkte skjerm-output (vis alle koder som standard karakterer)
12 | sett MSB (ascii grafikk)
27 | nullstill alle attributer (utenom farger)
# | Sett tekstfarge
30 | svart
31 | rød
32 | grønn
33 | gul
34 | blå
35 | magenta
36 | cyan
37 | grå
# | Sett bakgrunnsfarge
40 | svart
41 | rød
42 | grønn
43 | gul
44 | blå
45 | magenta
46 | cyan
47 | grå

Rapport kommandoer Ý È Þ
Kommando | Vert Forespørsel | TelNet98 Svar
Identifiser terminal | ESC Z | ESC [ 98 t
Send markør-posisjon | ESC [ 6 n | ESC [ # ; # R
Svar tilbake | ENQ | som definert
Send skjerm | ESC [ 2 i | skjerminnhold

Diverse kommandoer Ý È Þ
Kommando | Sekvens

Funksjonstaster
Slett alle merker | ESC [ z
Intialiser funksjonstaster # m/merke | ESC [ # z merke CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SKIFT>+F1 | - <SKIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SKIFT>+F1 | - <CTRL>+<SKIFT>+F12

PC Scancode Mode
Scancode mode på | ESC [ ? 34 h
Scancode mode av | ESC [ ? 34 l

Tekstbrytning EOL
Tekstbrytning på | ESC [ ? 7 h
Tekstbrytning av | ESC [ ? 7 l

PC Kommandoer
Tilkoblingsnavn | ESC [ x navn CR
Kjør lokalt program | ESC [ y kommando CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC karakterer
Vis PC karakterer # (=ascii) | ESC [ = # g

Skjermoppløsning
# Linjer, # Kolonner | ESC [ = # ; # R
# Linjer | ESC [ = # R
# Kolonner | ESC [ = 0 ; # R

Utskriftskommandoer Ý È Þ
Kommando | Sekvens
Printscreen | ESC [ i
Åpne lokal skriver | ESC [ 5 i
Avslutt lokal skriver | ESC [ 4 i
Eksempel på hvordan du kan bruke lokal utskrift

TelNet98 Printer-styring
Følgende sekvenser blir løst av Windows' egenstyrte GDI og derfor er disse uavhengige av eventuelle printer hardware:

Åpne lokal skriver; Retning: Stående | ESC [ 5 ; 30 i
Åpne lokal skriver; Retning: Liggende | ESC [ 5 ; 31 i
Åpne lokal skriver + Skriver Innstillinger | ESC [ 5 ; 32 i
EOL; utskriftsposisjon til pos. 0 på gjeldende linje | ESC [ 5 ; 2 i
LFBACK; linjefeed en linje tilbake | ESC [ 5 ; 3 i
CPI, # karakterer pr.tomme | ESC [ 5 ; 6 ; # i
sett utskriftsposisjon til kolonne # | ESC [ 5 ; 12 ; # i
Fet type på/av (#=1/0) | ESC [ 5 ; 14 ; # i
Nullstill alle attributer | ESC [ 5 ; 17 i
Understreking på/av (#=1/0) | ESC [ 5 ; 18 ; # i
Gjennomstrek på/av (#=1/0) | ESC [ 5 ; 19 ; # i
Subscript på/av (#=1/0) | ESC [ 5 ; 20 ; # i
Superscript på/av (#=1/0) | ESC [ 5 ; 21 ; # i
Dobbel høyde på/av (#=1/0) | ESC [ 5 ; 22 ; # i
Dobbel bredde på/av (#=1/0) | ESC [ 5 ; 23 ; # i
Sett sidelengde til # linjer | ESC [ 5 ; 24 ; # i
LPI, # Linjer pr.tomme | ESC [ 5 ; 26 ; # i
Kursiv på/av (#=1/0) | ESC [ 5 ; 27 ; # i
Marger - Topp (#=linjer) | ESC [ 5 ; 28 ; # i
Marger - Venstre (#=karakterer) | ESC [ 5 ; 29 ; # i

Mus kommandoer Ý È Þ
Kommando | Sekvens

Flytt markør til høyre/venstre
På | ESC [ 6 ; 1 ; 1 i
Av | ESC [ 6 ; 1 ; 0 i

Flytt markør opp/ned
På | ESC [ 6 ; 2 ; 1 i
Av | ESC [ 6 ; 2 ; 0 i

Venstre knapp
Av | ESC [ 6 ; 3 ; 0 i
Send CR | ESC [ 6 ; 3 ; 1 i
Send posisjon | ESC [ 6 ; 3 ; 2 i

Eksempel på ett utskrifts-script Ý È Þ

Enkelt shell-script for utskrift under UNIX®; Scriptet kan brukes som en kommando og som ett filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Filoverføring Ý È Þ

Overføring av filer over telnet-protokollen er ikke verdens raskeste metode for å transportere data gjennom ett nettverk - men det kan forenkle mye av arbeidet ettersom du kan overføre en fil bare ved å dra og slippe den i selve telnet-sesjonen - som allerede er åpnet. TelNet98 støtter binær overføring basert på UUCODE formatet.

Følgende krav stilles til serveren:
  • Kommandoer for å ta imot og sende UUCODE data:
    uuencode og uudecode finnes på de fleste UNIX®-baserte systemer idag. Dersom du ikke finner disse på serveren din kan de lastes ned fra GNU shareutils pakkene. Disse kan du hente ned fra internett eller via anonym ftp.
    (f.eks http://www.telnet98.com/gnu/)
  • Ett shell som kan motta kommandoer fra tastaturet (command prompt)
  • Nok rettigheter på serveren til å kunne kjøre

Opplasting av filer
Gjør følgende:
  1. Sjekk at du har tilgang på serveren
  2. Velg en eller flere filer fra Windows Utforsker
  3. Dra filen(e) med musen og slipp dem inn i din telnet98 sesjon

Nedlasting av filer
Gjør følgende:
  1. Sjekk at du har tilgang på serveren
  2. List ut filene du ønsker å laste ned ved å bruke f.eks kommandoen ls
  3. Velg en eller flere av filene med musen og kopier navnene til utklippstavlen
  4. Velg 'Rediger' -> 'Last ned filer' i sesjonsmenyen
  5. Velg så 'Lim Inn Filnavn fra Utklippstavlen'

terminfo Ý È Þ
Denne driveren kan brukes under UNIX® operativsystemer:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Denne driveren kan brukes under UNIX® operativsystemer:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Om PC-scancode Ý È Þ

Til forskjell fra standard terminaler som kun sender de tastetrykk som forekommer på ditt tastatur vil en PC-scancode kompatibel terminal være i stand til å sende "scancodes" (unike verdier assosiert med når du enten trykker ned en tast eller slipper den). Dersom en terminal kjører i PC-scancode mode vil den være i stand til å behandle flere tastetrykk enn vanlig karakter-basert mode vil gi. Dersom du for eksempel kjører i vanlig karakter-basert mode og trykker på tasten 'A' vil terminalen sende en enkel verdi (ASCII til 'A') til applikasjonen på serveren. Dersom du derimot setter terminalen til å bruke PC scancode mode vil den sende en verdi når du trykker ned tasten og en annen verdi når du slipper tasten. En scancode-applikasjon oversetter disse scancode verdiene basert på en keycode mapping på serveren. Eric's TelNet98 sender scancode til serveren dersom dette er aktivisert.

Anbefalt fremgangsmåte for å konfigurere ditt system for PC-scancode*)
  1. Overfør terminfo.src til serveren og kompiler filen med tic-kompilatoren:
    # tic terminfo.src
    Dette setter opp TERM=telnet98 som en egendefinert terminaltype.

  2. Sett termtypen i TelNet98 til telnet98

  3. Legg til en kommando for å aktivisere scancode mode i filen /etc/profile (standard på de fleste UNIX®-baserte systemer) eller i din private profil (f.eks .profile):

    eksempel:
    # aktiviser terminal's scancode
    # mode, dersom tilgjengelig
    if tput smsc
    then
    # aktivèr scanmode til vert
    stty isscancode xscancode
    fi
*) testet på SCO® UNIX® systemer; vil kanskje være noe forskjellig på andre systemer

© Friedrich Datentechnik GmbH. Alle rettigheter reservert.


Referência técnica
Ÿ | Comandos de cursor
Ÿ | Comandos de deslocamento
Ÿ | Comandos de edição
Ÿ | Comandos de atribuição
Ÿ | Comandos de relatórios
Ÿ | Comandos diversos
Ÿ | Comandos de impressora
Ÿ | Comandos do rato
Apêndice
Ÿ | Exemplo de como usar a impressão local
Ÿ | Transferência de ficheiros
Ÿ | Controlador Terminfo
Ÿ | Controlador Termcap
Ÿ | Sobre o PC-scancode
O Web site do Eric's TelNet98
ð | http://www.telnet98.com/
ð | F A Q - Perguntas mais frequentes
© Friedrich Datentechnik GmbH. Todos os direitos reservados.
Informação sobre o TelNet98

Comandos de cursor Ý È Þ
Comando | Sequência
Mover cursor # linhas acima | ESC [ # A
Mover cursor # linhas abaixo ESC [ # B
ESC [ # e
Mover cursor # colunas à direita ESC [ # C
ESC [ # a
Mover cursor # colunas à esquerda | ESC [ # D
Mover cursor # linhas abaixo; col=1 | ESC [ # E
Mover cursor # linhas acima; col=1 | ESC [ # F
Guardar a posição do cursor ESC [ s
ESC 7
Restaurar a posição do cursor ESC [ u
ESC 8
Definir posição do cursor - linha ; coluna ESC [ # ; # H
ESC [ # ; # f
Mover cursor para a linha # | ESC [ # d
Mover cursor # tabs atrás | ESC [ # Z
Modo regular do cursor | ESC [ 33 h
Modo intermitente do cursor | ESC [ 33 l
Cursor em forma de grifo | ESC [ 34 h
Cursor em forma de bloco | ESC [ 34 l
Cursor visível | ESC [ ? 25 h
Cursor invisível | ESC [ ? 25 l

Comandos de deslocamento Ý È Þ
Comando | Sequência
Deslocar uma linha para cima | ESC S
Deslocar # linhas para cima ESC [ # S
Deslocar uma linha para baixo | ESC T
Deslocar # linhas para baixo | ESC [ # T

Comandos de edição Ý È Þ
Comando | Sequência
Limpar o ecrã a partir do cursor | ESC [ J
Limpar o ecrã até o cursor | ESC [ 1 J
Limpar ecrã | ESC [ 2 J
Limpar a linha a partir do cursor | ESC [ K
Limpar a linha até o cursor | ESC [ 1 K
Limpar linha | ESC [ 2 K
Inserir # linhas | ESC [ # L
Eliminar # linhas | ESC [ # M
Inserir # caracteres | ESC [ # @
Eliminar # caracteres | ESC [ # P

Comandos de atribuição Ý È Þ
Comando | Sequência
Definir cor de primeiro plano para # | ESC [ = # F
Definir cor de segundo plano para # | ESC [ = # G
Definir cor de primeiro plano / segundo plano | ESC [ 2 ; # ; # m
# | Cor | # | Cor
0 | preto | 8 | cinza escuro
1 | azul | 9 | azul claro
2 | verde | 10 | verde claro
3 | turquesa | 11 | turquesa claro
4 | vermelho | 12 | vermelho claro
5 | magenta | 13 | magenta claro
6 | amarelo | 14 | amarelo claro
7 | cinza | 15 | branco
Definir atributo de ecrã | ESC [ # m
# | Geral
0 | redefinir todos os atributos
1 | primeiro plano brilhante/nítido
3 | segundo plano brilhante
4 | sublinhar
5 | piscar
7 | inverter
8 | entrada oculta
10 | limpar MSB (gráficos ascii)
11 | mudar para saída bruta (exibir todos os códigos como caracteres)
12 | definir MSB (gráficos ascii)
27 | redefinir todos os atributos (com excepção das cores)
# | Definir cor de primeiro plano
30 | preto
31 | vermelho
32 | verde
33 | amarelo
34 | azul
35 | magenta
36 | turquesa
37 | cinza
# | Definir cor de segundo plano
40 | preto
41 | vermelho
42 | verde
43 | amarelo
44 | azul
45 | magenta
46 | turquesa
47 | cinza

Comandos de relatórios Ý È Þ
Comando | Solicitação do anfitrião | Resposta do TelNet98
Identificar terminal | ESC Z | ESC [ 98 t
Enviar posição do cursor | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | como definido
Enviar ecrã | ESC [ 2 i | conteúdo do ecrã

Comandos diversos Ý È Þ
Comando | Sequência

Teclas de função
Limpar todos os rótulos | ESC [ z
Inicializar tecla de função # com o rótulo | ESC [ # z rótulo CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SHIFT>+F1 | - <SHIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SHIFT>+F1 | - <CTRL>+<SHIFT>+F12

PC Modo Scancode
Modo Scancode activado | ESC [ ? 34 h
Modo Scancode desactivado | ESC [ ? 34 l

Fim da moldagem de texto
Moldagem de texto activada | ESC [ ? 7 h
Moldagem de texto desactivada | ESC [ ? 7 l

Comandos PC
Definir nome de sessão | ESC [ x nome CR
Executar programa de PC local | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

Caracteres do PC
Exibir carácter # do PC (=ascii) | ESC [ = # g

Resolução do ecrã
# linhas, # colunas | ESC [ = # ; # R
# linhas | ESC [ = # R
# colunas | ESC [ = 0 ; # R

Comandos de impressora Ý È Þ
Comando | Sequência
Imprimir ecrã | ESC [ i
Impressora local aberta | ESC [ 5 i
Impressora local fechada | ESC [ 4 i
Exemplo de como usar a impressão local

Aperfeiçoamentos de impressão no TelNet98
As sequências seguintes são resolvidas pelo Windows GDI e desse modo são independentes de qualquer hardware de impressão:

Impressora local aberta; orientação: Vertical | ESC [ 5 ; 30 i
Impressora local aberta; orientação: Horizontal | ESC [ 5 ; 31 i
Impressora local aberta; mostrar diálogo de configuração da impressora | ESC [ 5 ; 32 i
EOL; definir posição de impressão como 0 na linha actual | ESC [ 5 ; 2 i
LFBACK; alimentação de linha uma linha para trás | ESC [ 5 ; 3 i
CPI, # caracteres por polegada | ESC [ 5 ; 6 ; # i
Definir posição de impressão na coluna # | ESC [ 5 ; 12 ; # i
Modo negrito lig/des (#=1/0) | ESC [ 5 ; 14 ; # i
Redefinir todos os atributos de acordo com o padrão | ESC [ 5 ; 17 i
Modo sublinhado lig/des (#=1/0) | ESC [ 5 ; 18 ; # i
modo rasurado lig/des (#=1/0) | ESC [ 5 ; 19 ; # i
Modo índice lig/des (#=1/0) | ESC [ 5 ; 20 ; # i
Modo expoente lig/des (#=1/0) | ESC [ 5 ; 21 ; # i
Modo de altura dupla lig/des (#=1/0) | ESC [ 5 ; 22 ; # i
Modo de largura dupla lig/des (#=1/0) | ESC [ 5 ; 23 ; # i
Definir o tamanho da página como # linhas | ESC [ 5 ; 24 ; # i
LPI, # linhas por polegada | ESC [ 5 ; 26 ; # i
Modo itálico lig/des (#=1/0) | ESC [ 5 ; 27 ; # i
Margem - topo (#=linhas) | ESC [ 5 ; 28 ; # i
Margem - esquerda (#=caracteres) | ESC [ 5 ; 29 ; # i

Comandos do rato Ý È Þ
Comando | Sequência

Mover cursor para a esquerda/direita
Activado | ESC [ 6 ; 1 ; 1 i
Desactivado | ESC [ 6 ; 1 ; 0 i

Mover cursor para cima / para baixo
Activado | ESC [ 6 ; 2 ; 1 i
Desactivado | ESC [ 6 ; 2 ; 0 i

Botão esquerdo
Desactivado | ESC [ 6 ; 3 ; 0 i
Enviar CR | ESC [ 6 ; 3 ; 1 i
Enviar posição | ESC [ 6 ; 3 ; 2 i

Exemplo de como usar a impressão local Ý È Þ

Script simples da shell para impressão no sistema operacional UNIX®. O script pode ser usado como um comando e também como um filtro:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Transferência de ficheiros Ý È Þ

A transferência de ficheiros com base em um protocolo telnet não é o método mais rápido de transferir dados através de uma rede. Todavia, o nível de comodidade é maior se for possível transferir um ficheiro apenas arrastando-o com o rato em uma sessão telnet. O TelNet98 suporta transferência binária baseada no formato de dados UUCODE.

Requisitos do anfitrião:
  • Comandos para recepção e emissão de dados codificados por UUCODE:
    uuencode e uudecode, invocados por TelNet98, já estão presentes na maior parte dos sistemas UNIX®. Caso não existam em seu anfitrião, as fontes dos programas estão disponíveis no pacote GNU Sharutils, que pode ser transferido da Internet ou obtido via ftp anónimo.
    (por exemplo, http://www.telnet98.com/gnu/)
  • Uma shell pronta para receber comandos do teclado (linha comandos)
  • Direitos suficientes no anfitrião para realizar tais operações

Envio de ficheiros
Passos sugeridos:
  1. Certifique-se de que os requisitos acima estejam satisfeitos.
  2. Seleccione um ou diversos ficheiros no Explorador do Windows
  3. Arraste o(s) ficheiro(s) com o rato e solte-os em sua sessão telnet

Recepção de ficheiros
Passos sugeridos:
  1. Certifique-se de que os requisitos acima estejam satisfeitos.
  2. Liste os ficheiros que deseja descarregar em seu ecrã do telnet usando, por exemplo, o comando ls do UNIX®.
  3. Seleccione um ou diversos dos ficheiros listados com o rato e copie os nomes na área de transferência.
  4. Seleccione 'Editar' -> Receber ficheiros ...' no menu da sessão
  5. Na caixa de diálogo que surge prima o botão 'Colar nomes da área de transferência'

terminfo Ý È Þ
O controlador pode ser usado nos sistemas operacionais UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
O controlador pode ser usado nos sistemas operacionais UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Sobre o PC-scancode Ý È Þ

Diferentemente dos terminais padrão, que enviam informações para o anfitrião apenas na forma dos valores impressos nas próprias teclas, um terminal com recursos PC-scancode pode também enviar scancodes (valores únicos associados com a pressão e a libertação de uma tecla). A operação de um terminal no modo PC-scancode permite que uma aplicação scancode obtenha uma introdução de dados por teclado mais precisa que o modo de texto permitiria. Por exemplo, se definir seu terminal para modo de texto e premir a tecla identificada como 'A', seu terminal envia um único valor (o valor ASCII de 'A') para sua aplicação. Todavia, se definir seu terminal para modo scancode e premir a tecla identificada como 'A', seu terminal envia um valor quando prime a tecla e um segundo valor quando a liberta. Uma aplicação scancode traduz esses valores scancode de acordo com um mapa predeterminado no anfitrião. O Eric's TelNet98 envia scancodes para o anfitrião quando o modo scancode é activado.

Passos sugeridos para configurar seu sistema para o PC-scancode*)
  1. Transfira o terminfo.src para seu anfitrião e compile-o usando o compilador tic:
    # tic terminfo.src
    Isso irá criar para você um termtype TERM=telnet98

  2. No TelNet98 sua caixa de diálogo aberta define o termtype como telnet98

  3. Acrescente um comando para activar o modo scancode para seu /etc/profile (por todo o sistema) ou para seu .profile (privado apenas):

    por exemplo:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the anfitrião
    stty isscancode xscancode
    fi
*) testado em um sistema SCO® UNIX®; pode ser diferente em outros sistemas

© Friedrich Datentechnik GmbH. Todos os direitos reservados.


Referencia Técnica
Ÿ | Secuencias de los Comandos del Cursor
Ÿ | Secuencias de los Comandos Scroll
Ÿ | Secuencias de los Comandos Editar
Ÿ | Secuencias de los Comandos Attribute
Ÿ | Secuencias de los Comandos de Informes
Ÿ | Secuencias de Comandos Varios
Ÿ | Secuencias de los Comandos de Impresión
Ÿ | Secuencias de los Comandos del Mouse
Indice
Ÿ | Ejemplos del Print Script
Ÿ | Transferencia de archivos
Ÿ | Driver Terminfo
Ÿ | Driver Termcap
Ÿ | Acerca del PC-scancode
TelNet98 Web Site
ð | http://www.telnet98.com/
ð | F A Q - Frequently Asked Questions
© Friedrich Datentechnik GmbH. Todos los derechos reservados.
Ayuda sobre TelNet98

Comandos del Cursor Ý È Þ
Comando | Secuencia
Cursor # lineas hacia arriba | ESC [ # A
Cursor # lineas hacia abajo ESC [ # B
ESC [ # e
Cursor # columnas a la derecha ESC [ # C
ESC [ # a
Cursor # columnas a la izquierda | ESC [ # D
Cursor # lineas hacia abajo; col=1 | ESC [ # E
Cursor # lineas hacia arriba; col=1 | ESC [ # F
Grabar la posición del cursor ESC [ s
ESC 7
Devolver la posición del cursor ESC [ u
ESC 8
Fijar la posición línea ; columna ESC [ # ; # H
ESC [ # ; # f
Cursor a la linea # | ESC [ # d
Cursor # tabs atrás | ESC [ # Z
Cursor en modo fijo | ESC [ 33 h
Cursor en modo titilante | ESC [ 33 l
Cursor de subrayado | ESC [ 34 h
Cursor de block | ESC [ 34 l
Cursor visible | ESC [ ? 25 h
Cursor invisible | ESC [ ? 25 l

Comandos Scroll Ý È Þ
Comando | Secuencia
Scroll una línea arriba | ESC S
Scroll # líneas arriba ESC [ # S
Scroll una línea abajo | ESC T
Scroll # líneas abajo | ESC [ # T

Comandos de Edición Ý È Þ
Comando | Secuencia
Clear screen desde el cursor | ESC [ J
Clear screen al cursor | ESC [ 1 J
Clear screen | ESC [ 2 J
Clear línea desde el cursor | ESC [ K
Clear línea al cursor | ESC [ 1 K
Clear línea | ESC [ 2 K
Insertar # líneas | ESC [ # L
Borrar # líneas | ESC [ # M
Insertar # caracteres | ESC [ # @
Borrar # caracteres | ESC [ # P

Comandos Attribute Ý È Þ
Comando | Secuencia
Fijar los colores de primer plano a # | ESC [ = # F
Fijar los colores de fondo a # | ESC [ = # G
Colores de primer plano / fondo | ESC [ 2 ; # ; # m
# | Color | # | Color
0 | negro | 8 | gris oscuro
1 | azul | 9 | celeste
2 | verde | 10 | verde claro
3 | cyan | 11 | cyan claro
4 | rojo | 12 | rosado
5 | magenta | 13 | magenta claro
6 | amarillo | 14 | amarillo claro
7 | gris | 15 | blanco
Fijar los atributos de la pantalla | ESC [ # m
# | General
0 | devolver todos los atributos
1 | primer plano en modo resaltado o negritas
3 | fondo en modo resaltado
4 | subrayado
5 | intermitencia activada
7 | modo inverso
8 | input oculto
10 | limpiar MSB (gráficos ascii)
11 | cambiar a un output "en crudo" (muestra todos los codigos como caracteres)
12 | fijar MSB (gráficos ascii)
27 | devolver todos los atributos (excepto los colores)
# | Fijar los colores de primer plano
30 | negro
31 | rojo
32 | verde
33 | amarillo
34 | azul
35 | magenta
36 | cyan
37 | gris
# | Fijar los colores de fondo
40 | negro
41 | rojo
42 | verde
43 | amarillo
44 | azul
45 | magenta
46 | cyan
47 | gris

Comandos de Informes Ý È Þ
Comando | Requerimiento del Host | TelNet98 Response
Identifica la Terminal | ESC Z | ESC [ 98 t
Posición del Cursor | ESC [ 6 n | ESC [ # ; # R
Respuesta Recibida | ENQ | tal como se definió
Enviar Pantalla | ESC [ 2 i | contenido de la pantalla

Comandos Varios Ý È Þ
Comando | Secuencia

Teclas de Función
Limpiar todas las Etiquetas | ESC [ z
Inicializar la tecla de función # con Etiqueta | ESC [ # z etiqueta CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <MAYÚS>+F1 | - <MAYÚS>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<MAYÚS>+F1 | - <CTRL>+<MAYÚS>+F12

Modo Scancode de la PC
Modo Scancode en on | ESC [ ? 34 h
Modo Scancode en off | ESC [ ? 34 l

Fin de Línea
Wrap de Linea on | ESC [ ? 7 h
Wrap de Linea off | ESC [ ? 7 l

Comandos de la PC
Nombre de Sesión | ESC [ x nombre CR
Ejecutar un programa local en la PC | ESC [ y comando CR
ShellExec | ESC [ yShellExec SP shlobj CR

Caracteres de la PC
Mostrar el carácter # (=ascii) | ESC [ = # g

Área del Escritorio
# Lineas, # Columnas | ESC [ = # ; # R
# Lineas | ESC [ = # R
# Columnas | ESC [ = 0 ; # R

Comandos de Impresora Ý È Þ
Comando | Secuencia
Hardcopy | ESC [ i
Abrir una impresora local | ESC [ 5 i
Cerrar una impresora local | ESC [ 4 i
Ejemplos de cómo usar una impresora local

Mejoras de la Impresora TelNet98
Windows GDI resuelve las siguientes secuencias y hasta tanto, son independentes de cualquier hardware de impresora específico:

Abrir una impresora local; Orientación: Vertical | ESC [ 5 ; 30 i
Abrir una impresora local; Orientación: Horizontal | ESC [ 5 ; 31 i
Abrir una impresora local + Configuración de lmpresión | ESC [ 5 ; 32 i
EOL; ubica la posición de impresión a la posición 0 en la línea actual | ESC [ 5 ; 2 i
LFBACK; retrocede una línea | ESC [ 5 ; 3 i
CPI, # caracteres por pulgada | ESC [ 5 ; 6 ; # i
Ubicar la posición de impresión a la columna # | ESC [ 5 ; 12 ; # i
Negritas on/off (#=1/0) | ESC [ 5 ; 14 ; # i
Volver todos los atributos a valores por defecto | ESC [ 5 ; 17 i
Subrayado on/off (#=1/0) | ESC [ 5 ; 18 ; # i
Tachado on/off (#=1/0) | ESC [ 5 ; 19 ; # i
Modo Subscript on/off (#=1/0) | ESC [ 5 ; 20 ; # i
Modo Superscript on/off (#=1/0) | ESC [ 5 ; 21 ; # i
Double alto on/off (#=1/0) | ESC [ 5 ; 22 ; # i
Double ancho on/off (#=1/0) | ESC [ 5 ; 23 ; # i
Fijar la longitud de página a # líneas | ESC [ 5 ; 24 ; # i
LPI, # líneas por pulgada | ESC [ 5 ; 26 ; # i
Modo Italic on/off (#=1/0) | ESC [ 5 ; 27 ; # i
Márgenes - Superior (#=líneas) | ESC [ 5 ; 28 ; # i
Márgenes - Izquierda (#=caracteres) | ESC [ 5 ; 29 ; # i

Comandos del Mouse Ý È Þ
Comando | Secuencia

Cursor a la derecha/izquierda
On | ESC [ 6 ; 1 ; 1 i
Off | ESC [ 6 ; 1 ; 0 i

Cursor hacia arriba/abajo
On | ESC [ 6 ; 2 ; 1 i
Off | ESC [ 6 ; 2 ; 0 i

Botón izquierdo
Off | ESC [ 6 ; 3 ; 0 i
Enviar CR | ESC [ 6 ; 3 ; 1 i
Enviar Posición | ESC [ 6 ; 3 ; 2 i

Ejemplos de Impresión Ý È Þ

Simple shell script para imprimir bajo el sistema operativo UNIX®; El script se puede usar como un comando y también como un filtro:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Transferencia de archivos Ý È Þ

La transferencia de archivos a través de protocolos TELNET no es el método más rápido para transportar datos en una red. Sin embargo, aumenta el nivel de confort al permitir transferir archivos arrastrándolos con el mouse a una sesión Telnet abierta. TelNet98 soporta transferencias binarias basadas en el formato UUCODE.

Requerimientos del Host:
  • Comandos para la recepción y el envío de datos codificados con UUCODE:
    Los comandos uuencode y uudecode, que son invocados por TelNet98, están presentes en la mayoría de los sistemas UNIX®. Si no se encuentran en su Host, están disponibles en el paquete GNU Sharutils, que puede ser bajado de Internet o utilizando FTP Anónimo.
    (ej. http://www.telnet98.com/gnu/)
  • Un intérprete de comandos (shell) listo para recibir comandos del teclado
  • Suficientes derechos en el Host como para llevar a cabo dichas operaciones

Transferencia hacia el host (Cargar)
Pasos sugeridos:
  1. Asegúrese de cumplir con los requerimientos anteriores
  2. Seleccione uno o más archivos con el Explorador de Windows
  3. Arrastre los archivos con el mouse y suéltelos dentro de la ventana donde está corriendo su sesión TELNET

Transferencia desde el Host (Descargar)
Pasos sugeridos:
  1. Asegúrese de cumplir con los requerimientos anteriores
  2. Liste los archivos que desea transferir en su sesión Telnet, por ejemplo, utilizando el comando de Unix® ls
  3. Seleccione uno o más archivos utilizando el mouse y copie los nombres al portapapeles
  4. Seleccione 'Edición' -> 'Descargar' en la sesión Telnet
  5. En la ventana de diálogo que aparece, seleccione el directorio en el que quiere copiar los archivos y presione 'Pegar archivos desde el portapapeles'

terminfo Ý È Þ
Se puede usar este driver bajo el sistema operativo UNIX®:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Se puede usar este driver bajo el sistema operativo UNIX®:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Acerca del PC-scancode Ý È Þ

A diferencia de las terminales standard que envían la información al host solo en forma de valores Keytop (los caracteres que aparecen en la superficie del teclado), una terminal PC-scancode también puede enviar códigos (valores asociados a presionar y a soltar cada tecla). Trabajar en modo PC-scancode permite a la aplicación acceder a más definiciones que el modo carácter podría facilitar. Por ejemplo, si configura su terminal en modo carácter y pulsa la tecla 'A', la terminal envía un valor simple (el valor ASCII de 'A') a la aplicación. Pero si configura su terminal en modo scancode y presiona la tecla 'A', la terminal envía un valor cuando presione la tecla y un segundo valor cuando la suelte. Una aplicación scancode traduce estos valores scancode de acuerdo a un mapeo predeterminado en el huesped. Eric's TelNet98 envía scancodes al huesped cuando se habilita el modo scancode.

Pasos sugeridos para configurar su sistema para PC-scancode*)
  1. Transfiera terminfo.src y compílelo usando el tic compiler:
    # tic terminfo.src
    Esto creará un tipo de terminal con TERM=telnet98

  2. En la ventana de inicio de TelNet98 ingrese el tipo de terminal como telnet98

  3. Agregue un comando para habilitar el modo scancode en su archivo /etc/profile (para usarlo en todo el sistema) o a su .profile (para su uso personal):

    ej.:
    # habilita el scancode de la
    # terminal modo, si existiese
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) probado bajo SCO® UNIX®; podría resultar completamente distinto en otros sistemas

© Friedrich Datentechnik GmbH. Todos los derechos reservados.


Teknisk referens
Ÿ | Markörkommandosekvenser
Ÿ | Rullningskommandosekvenser
Ÿ | Redigeringskommandosekvenser
Ÿ | Attributkommandosekvenser
Ÿ | Rapportkommandosekvenser
Ÿ | Diverse kommandosekvenser
Ÿ | Skrivarkommandosekvenser
Ÿ | Muskommandosekvenser
Bilaga
Ÿ | Exempel på utskriftsskript
Ÿ | Filöverföring
Ÿ | Terminfo-drivrutin
Ÿ | Termcap-drivrutin
Ÿ | Om PC-scankod
TelNet98:s webbplats
ð | http://www.telnet98.com/
ð | F A Q - Vanliga frågor och svar
© Friedrich Datentechnik GmbH. Alla rättigheter förbehålles.
Information om TelNet98

Markörkommandon Ý È Þ
Kommando | Sekvens
Flytta markören # rader uppåt | ESC [ # A
Flytta markören # rader nedåt ESC [ # B
ESC [ # e
Flytta markören # kolumner åt höger ESC [ # C
ESC [ # a
Flytta markören # kolumner åt vänster | ESC [ # D
Flytta markören # rader nedåt; kolumn=1 | ESC [ # E
Flytta markören # rader uppåt; kolumn=1 | ESC [ # F
Spara markörens position ESC [ s
ESC 7
Återställ markörens position ESC [ u
ESC 8
Ange markörens position - rad; kolumn ESC [ # ; # H
ESC [ # ; # f
Flytta markören till rad # | ESC [ # d
Flytta markören # tabbar bakåt | ESC [ # Z
Fast markör | ESC [ 33 h
Blinkande markör | ESC [ 33 l
Understrykningsmarkör | ESC [ 34 h
Blockmarkör | ESC [ 34 l
Synlig markör | ESC [ ? 25 h
Osynlig markör | ESC [ ? 25 l

Rullningskommandon Ý È Þ
Kommando | Sekvens
Rulla en rad uppåt | ESC S
Rulla # rader uppåt ESC [ # S
Rulla en rad nedåt | ESC T
Rulla # rader nedåt | ESC [ # T

Redigeringskommandon Ý È Þ
Kommando | Sekvens
Rensa skärmen fr.o.m. markören | ESC [ J
Rensa skärmen fram till markören | ESC [ 1 J
Rensa skärmen | ESC [ 2 J
Rensa raden fr.o.m. markören | ESC [ K
Rensa raden fram till markören | ESC [ 1 K
Rensa raden | ESC [ 2 K
Infoga # rader | ESC [ # L
Ta bort # rader | ESC [ # M
Infoga # tecken | ESC [ # @
Ta bort # tecken | ESC [ # P

Attributkommandon Ý È Þ
Kommando | Sekvens
Ange förgrundsfärg | ESC [ = # F
Ange bakgrundsfärg | ESC [ = # G
Ange förgrunds-/ bakgrundsfärg | ESC [ 2 ; # ; # m
# | Färg | # | Färg
0 | svart | 8 | mörkgrå
1 | blå | 9 | ljusblå
2 | grön | 10 | ljusgrön
3 | cyan | 11 | ljus cyan
4 | röd | 12 | ljusröd
5 | magenta | 13 | ljus magenta
6 | gul | 14 | ljusgul
7 | grå | 15 | vit
Ange skärmattribut | ESC [ # m
# | Allmänt
0 | återställ alla attribut
1 | ljus/mörk förgrund
3 | ljus bakgrund
4 | understruken
5 | blinka
7 | omvänd
8 | dold inmatning
10 | rensa MSB (ascii-grafik)
11 | växla till rå utmatning (visa alla koder som tecken)
12 | ange MSB (ascii-grafik)
27 | återställ alla attribut (utom färger)
# | Ange förgrundsfärg
30 | svart
31 | röd
32 | grön
33 | gul
34 | blå
35 | magenta
36 | cyan
37 | grå
# | Ange bakgrundsfärg
40 | svart
41 | röd
42 | grön
43 | gul
44 | blå
45 | magenta
46 | cyan
47 | grå

Rapportkommandon Ý È Þ
Kommando | Förfrågan från värddator | TelNet98:s svar
Identifiera terminal | ESC Z | ESC [ 98 t
Markörposition vid sändning | ESC [ 6 n | ESC [ # ; # R
Answerback | ENQ | enligt angivning
Fönstret Skicka | ESC [ 2 i | skärminnehåll

Diverse kommandon Ý È Þ
Kommando | Sekvens

Funktionstangenter
Rensa alla beteckningar | ESC [ z
Initiera funktionstangent # med beteckning | ESC [ # z beteckning CR
#1 | - #12 = F1 | - F12
#13 | - #24 = <SKIFT>+F1 | - <SKIFT>+F12
#25 | - #36 = <CTRL>+F1 | - <CTRL>+F12
#37 | - #48 = <CTRL>+<SKIFT>+F1 | - <CTRL>+<SKIFT>+F12

Läge för PC-scankod
Läge för scankod på | ESC [ ? 34 h
Läge för scankod av | ESC [ ? 34 l

Slut på radbrytning
Radbrytning på | ESC [ ? 7 h
Radbrytning av | ESC [ ? 7 l

PC-kommandon
Ange sessionsnamn | ESC [ x namn CR
Kör lokalt PC-program | ESC [ y prog CR
ShellExec | ESC [ yShellExec SP shlobj CR

PC-tecken
Visa PC-tecken # (=ascii) | ESC [ = # g

Skärmupplösning
# rader, # kolumner | ESC [ = # ; # R
# rader | ESC [ = # R
# kolumner | ESC [ = 0 ; # R

Skrivarkommandon Ý È Þ
Kommando | Sekvens
Skriv ut fönstret | ESC [ i
Öppna lokal skrivare | ESC [ 5 i
Stäng lokal skrivare | ESC [ 4 i
Exempel på hur lokal utskrift kan användas

Skrivarförbättringar med TelNet98
Följande sekvenser har Windows GDI-upplösning och därför är de oberoende av all specifik maskinvara för skrivare:

Öppna lokal skrivare; Orientering: Stående | ESC [ 5 ; 30 i
Öppna lokal skrivare; Orientering: Liggande | ESC [ 5 ; 31 i
Öppna lokal skrivare; visa dialogrutan Skrivarinställningar | ESC [ 5 ; 32 i
EOL; ange utskriftsposition till pos 0 på aktuell rad | ESC [ 5 ; 2 i
LFBACK; radmatning en rad bakåt | ESC [ 5 ; 3 i
CPI, # tecken per tum | ESC [ 5 ; 6 ; # i
Ange utskriftsposition till kolumn # | ESC [ 5 ; 12 ; # i
Fetstil på/av (#=1/0) | ESC [ 5 ; 14 ; # i
Återställ alla attribut till standard | ESC [ 5 ; 17 i
Understrykning på/av (#=1/0) | ESC [ 5 ; 18 ; # i
Genomstrykning på/av (#=1/0) | ESC [ 5 ; 19 ; # i
Subskript på/av (#=1/0) | ESC [ 5 ; 20 ; # i
Superskript på/av (#=1/0) | ESC [ 5 ; 21 ; # i
Läge för dubbel höjd på/av (#=1/0) | ESC [ 5 ; 22 ; # i
Läge för dubbel bredd på/av (#=1/0) | ESC [ 5 ; 23 ; # i
Ange sidlängd till # rader | ESC [ 5 ; 24 ; # i
LPI, # rader per tum | ESC [ 5 ; 26 ; # i
Kursiv på/av (#=1/0) | ESC [ 5 ; 27 ; # i
Marginal - Överkant (#=rader) | ESC [ 5 ; 28 ; # i
Marginal - Vänster (#=tecken) | ESC [ 5 ; 29 ; # i

Muskommandon Ý È Þ
Kommando | Sekvens

Flytta markören åt vänster/höger
Aktiverad | ESC [ 6 ; 1 ; 1 i
Inaktiverad | ESC [ 6 ; 1 ; 0 i

Flytta markören uppåt/nedåt
Aktiverad | ESC [ 6 ; 2 ; 1 i
Inaktiverad | ESC [ 6 ; 2 ; 0 i

Vänsterknapp
Inaktiverad | ESC [ 6 ; 3 ; 0 i
Skicka CR | ESC [ 6 ; 3 ; 1 i
Skicka position | ESC [ 6 ; 3 ; 2 i

Exempel på utskriftsskript Ý È Þ

Enkelt skript för användargränssnitt för utskrift i operativsystemet UNIX®. Skriptet kan användas som kommando och filter:

:
# Sample Print Script
########################################
ESC=`echo|awk '{ printf("%c",27) }'`
OPEN_PRINTER="${ESC}[5i"
CLOSE_PRINTER="${ESC}[4i"

Filter()
{
echo "${OPEN_PRINTER}" | tr -d "\012"
cat
echo "${CLOSE_PRINTER}" | tr -d "\012"
}

PrintFile()
{
MY_NAME=$1
shift 1
for FILE in $*
do
echo ${FILE}
[ -r ${FILE} ] || {
echo "${MY_NAME}: cannot open ${FILE}" >&2
continue
}
Filter < ${FILE}
done
}

#
# main
#------------------------------------
#
trap "" 1 2 3
if expr $# \> 0 >/dev/null 2>&1
then
PrintFile $0 $*
else
Filter
fi

Filöverföring Ý È Þ

Att överföra filer över ett telnetprotokoll är inte det snabbaste sättet att förflytta data via ett nätverk. Det är dock mycket bekvämt och praktiskt att kunna överföra en fil genom att bara dra den med musen till en telnetsession som redan är öppen. TelNet98 stöder binär överföring, baserat på UUCODE dataformat.

Krav på värddatorn
  • Kommandon för att ta emot och skicka UUCODE data:
    uuencode och uudecode, som framkallas av TelNet98 finns redan i de flesta UNIX®-system. Om de saknas på din värddator finns programkällorna tillgängliga i programpaketet GNU Sharutils som kan hämtas från internet eller via anonym ftp.
    (t.ex. http://www.telnet98.com/gnu/)
  • Ett användargränssnitt som är redo för att ta emot kommandon från tangentbordet (kommandoprompt)
  • Tillräcklig behörighet hos värddatorn för att utföra sådana åtgärder

Filuppladdning
föreslagna steg:
  1. Se till att ovanstående krav är uppfyllda
  2. Välj en eller flera filer i Utforskaren
  3. Dra filen/-erna med musen och släpp den/dem i din telnet-session

Filhämtning
föreslagna steg:
  1. Se till att ovanstående krav är uppfyllda
  2. Ange de filer du vill hämta till din telnet-skärm genom att t.ex. använda kommandot UNIX® ls
  3. Markera en eller flera av de angivna filerna med musen och kopiera namnen till urklipp
  4. Välj 'Redigera' -> 'Klistra in filer' i sessionsmenyn
  5. I dialogrutan som visas trycker du på knappen 'Klistra in filnamn från Urklipp'

terminfo Ý È Þ
Den här drivrutinen kan användas i UNIX®-operativsystem:
#
# Terminfo source for a
#
# TERM=telnet98
#
# terminal type
# Use the terminfo compiler 'tic' for compilation
#
telnet98|Eric's TelNet98 - ANSI Terminal,
am, bce, eo, lh#1, lw#30, nlab#36, colors#8, pairs#64,
setb=\E[4%p1%dm, setf=\E[3%p1%dm, pln=\E[%p1%dz%p2%s\r,
op=\E[0;37;40m\E[?7h, smacs=\E[11m, rmacs=\E[10m,
acsc=`*0\333+\257\,\256iIa\260h\261~\372f\370j\331k\277l\332m\300t\303u\264v\301w\302q\304x\263n\305g\361,
cbt=\E[Z, bel=\7, cr=\r, ff=\f, ht=\t, kbs=\b,
clear=\f, el1=\E[1K, el=\E[K, ed=\E[J, kdch1=\177,
cup=\E[%i%p1%d;%p2%dH, ind=\ES, ri=\ET, home=\E[H,
cud1=\E[B, cub1=\b, cuu1=\E[A, cuf1=\E[C, ll=\E[100E,
civis=\E[?25l, cnorm=\E[?25h, cvvis=\E[?25h,
smsc=\E[?34h, rmsc=\E[?34l, smln=\E[z, rmln=\E[z,
dch1=\E[P, dl1=\E[M, dispc=\E[=%p1%dg, ich1=\E[@, il1=\E[L,
dch=\E[%p1%dP, dl=\E[%p1%dM, cud=\E[%p1%dB, ich=\E[%p1%d@,
indn=\E[%p1%dS, il=\E[%p1%dL, cub=\E[%p1%dD, cuf=\E[%p1%dC,
rin=\E[%p1%dT, cuu=\E[%p1%dA, mc0=\E[i, mc5=\E[5i, mc4=\E[4i,
sc=\E7, rc=\E8, hpa=\E[%p1%dd, smso=\E[0;3;7m, rmso=\E[m,
dim=\E[m, rev=\E[7m, invis=\E[8m, bold=\E[1m, blink=\E[5m,
smam=\E[?7h, rmam=\E[?7l, smul=\E[4m, rmul=\E[27m,
#
# the following parameters
# could be overridden by TelNet98's setup:
#
##################################################
lines#25, cols#80, it#8,
kcuu1=\E[A, kcud1=\E[B, kcuf1=\E[C, kcub1=\E[D,
kend=\E[F, knp=\E[G, khome=\E[H, kpp=\E[I,
kich1=\E[L, kcbt=\E[Z, kdch1=\0177,
kf1=\E[M, kf2=\E[N, kf3=\E[O, kf4=\E[P, kf5=\E[Q, kf6=\E[R,
kf7=\E[S, kf8=\E[T, kf9=\E[U, kf10=\E[V, kf11=\E[W, kf12=\E[X,
kf13=\E[Y, kf14=\E[Z, kf15=\E[a, kf16=\E[b, kf17=\E[c, kf18=\E[d,
kf19=\E[e, kf20=\E[f, kf21=\E[g, kf22=\E[h, kf23=\E[i, kf24=\E[j,
kf25=\E[k, kf26=\E[l, kf27=\E[m, kf28=\E[n, kf29=\E[o, kf30=\E[p,
kf31=\E[q, kf32=\E[r, kf33=\E[s, kf34=\E[t, kf35=\E[u, kf36=\E[v,
##################################################
#

termcap Ý È Þ
Den här drivrutinen kan användas i UNIX®-operativsystem:
#
# TelNet98 termcap driver
#
telnet98:\
:al=\E[L:am:eo:bs:cd=\E[J:ce=\E[K:cl=\f:cm=\E[%i%d;%dH:\
:dc=\E[P:dl=\E[M:do=\E[B:bt=\E[Z:Co#8:pa#64:\
:op=\E[0;1m\E[?7h:ho=\E[H:ic=\E[@:nd=\E[C:pt:\
:so=\E[0;3;7m:se=\E[m:us=\E[2;9m:ue=\E[m:up=\E[A:\
:kD=\177:kb=\b:sf=\ES:sr=\ET:bl=\7:cr=\r:ff=\f:ta=\t:cb=\E[1K:\
:ll=\E[100E:vi=\E[?25l:ve=\E[?25h:vs=\E[34l:\
:mb=\E[5m:md=\E[0;1m:me=\E[10;0m:mh=\E[m:mr=\E[7m:\
:mk=\E[8m:Sb=\E[4%dm:Sf=\E[3%dm:SA=\E[?7h:RA=\E[?7l:\
:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
:SF=\E[%dS:AL=\E[%dL:LE=\E[%dD:RI=\E[%dC:SR=\E[%dT:\
:UP=\E[%dA:ps=\E[i:po=\E[5i:pf=\E[4i:sc=\E7:rc=\E8:le=\b:\
:GS=\E[12m:GE=\E[10m:GV=\63:GH=D:GC=E:GL=\64:GR=C:\
:RT=^J:G1=?:G2=Z:G3=@:G4=Y:G5=;:G6=I:G7=H:G8=<:GU=A:\
:GD=B:CW=\E[M:NU=\E[N:RF=\E[O:RC=\E[P:WL=\E[S:WR=\E[T:\
:CL=\E[U:CR=\E[V:HM=\E[H:EN=\E[F:PU=\E[I:PD=\E[G:Gc=N:\
:Gd=K:Gh=M:Gl=L:Gu=J:Gv=\072:li#25:co#80:it#8:\
:ku=\E[A:kd=\E[B:kr=\E[C:kl=\E[D:@7=\E[F:kN=\E[G:kh=\E[H:\
:kP=\E[I:kI=\E[L:kB=\E[Z:

Om PC-scankod Ý È Þ

Till skillnad från standardterminaler som endast skickar information till värddatorn i form av tangentvärden (de tecken som syns på tangenterna), kan en terminal med PC-scankodkapacitet även skicka scankoder (unika värden som är associerade med att varje tangent trycks ned och släpps upp). Genom att köra en terminal i läget för PC-scankod ger ett scankodprogram mer distinkta tangentbordstryckningar än vid teckenläge. Om du t.ex. ställer in din terminal till teckenläge och trycker på tangenten 'A' skickar din terminal ett enstaka värde (ASCII-värdet 'A') till ditt program. Om du ställer in din terminal till scankodläge och trycker på tangenten 'A' skickar din terminal ett värde när du trycker ned tangenten och ett annat värde när du släpper upp tangenten. Ett scankodprogram omvandlar de här scankodvärdena enligt en förbestämd tilldelning på värddatorn. Eric's TelNet98 skickar scankoder till värddatorn när scankodläge aktiveras.

Föreslagna steg för att konfigurera ditt system för PC-scankod*)
  1. Överför terminfo.src till din värddator och kompilera den med kompilatorn tic:
    # tic terminfo.src
    Då skapas termtypen TERM=telnet98.

  2. I Egenskaper för TelNet98-session anger du termtypen telnet98

  3. Lägg till ett kommando för att aktivera scankodläge till din /etc/profile (i hela systemet) eller till din .profile (endast privat):

    t.ex.:
    # enable the terminal's scancode
    # mode, if available
    if tput smsc
    then
    # enable scancode mode on the host
    stty isscancode xscancode
    fi
*) testad på ett SCO® UNIX®-system; kan vara annorlunda på andra system

© Friedrich Datentechnik GmbH. Alla rättigheter förbehålles.